summaryrefslogtreecommitdiffstats
path: root/src/mesa/main/tests/meson.build
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2018-11-19 13:44:15 -0800
committerDylan Baker <[email protected]>2018-11-20 09:09:22 -0800
commita999798daad7181110922a7e756eb1d8dfe55c4e (patch)
treedd7d629beec14d57d406a8852717b32726d6888d /src/mesa/main/tests/meson.build
parentb787dcf57b7298868ce9b6885a827d57a6127ba1 (diff)
meson: Add tests to suites
Meson test has a concepts of suites, which allow tests to be grouped together. This allows for a subtest of tests to be run only (say only the tests for nir). A test can be added to more than one suite, but for the most part I've only added a test to a single suite, though I've added a compiler group that includes nir, glsl, and glcpp tests. To use this you'll need to invoke meson test directly, instead of ninja test (which always runs all targets). it can be invoked as: `meson test -C builddir --suite $suitename` (meson test has addition options that are pretty useful). Tested-By: Gert Wollny <[email protected]> Acked-by: Eric Engestrom <[email protected]>
Diffstat (limited to 'src/mesa/main/tests/meson.build')
-rw-r--r--src/mesa/main/tests/meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/mesa/main/tests/meson.build b/src/mesa/main/tests/meson.build
index d1bd81a5604..4b39325154e 100644
--- a/src/mesa/main/tests/meson.build
+++ b/src/mesa/main/tests/meson.build
@@ -41,5 +41,6 @@ test(
include_directories : [inc_include, inc_src, inc_mapi, inc_mesa],
dependencies : [idep_gtest, dep_clock, dep_dl, dep_thread],
link_with : [libmesa_classic, link_main_test],
- )
+ ),
+ suite : ['mesa'],
)