summaryrefslogtreecommitdiffstats
path: root/src/mesa/main/tests/Makefile.am
diff options
context:
space:
mode:
authorIan Romanick <[email protected]>2012-05-25 08:26:33 -0700
committerIan Romanick <[email protected]>2012-06-13 13:14:22 -0700
commit8fecdcc587a192c0ea4e13d59321691b8981c249 (patch)
tree33831bce05241bf16e1bb629ae1d6591b835b98f /src/mesa/main/tests/Makefile.am
parente08f9080ff6ca8af025eeeeb40f328f3279cf40a (diff)
mesa/tests: Add tests for _mesa_lookup_enum_by_{name,nr} functions
Signed-off-by: Ian Romanick <[email protected]> Reviewed-by: Brian Paul <[email protected]>
Diffstat (limited to 'src/mesa/main/tests/Makefile.am')
-rw-r--r--src/mesa/main/tests/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/src/mesa/main/tests/Makefile.am b/src/mesa/main/tests/Makefile.am
new file mode 100644
index 00000000000..12f26b20409
--- /dev/null
+++ b/src/mesa/main/tests/Makefile.am
@@ -0,0 +1,17 @@
+AM_CPPFLAGS = \
+ -I$(top_builddir)/src/gtest/include \
+ -I$(top_builddir)/src/mapi \
+ -I$(top_builddir)/src/mesa \
+ -I$(top_builddir)/include \
+ $(X11_CFLAGS)
+
+TESTS = main-test
+check_PROGRAMS = main-test
+
+main_test_SOURCES = \
+ enum_strings.cpp
+
+main_test_LDADD = \
+ $(top_builddir)/src/mesa/libmesa.a \
+ $(top_builddir)/src/gtest/libgtest.la \
+ -lpthread