summaryrefslogtreecommitdiffstats
path: root/src/mesa/main/tests/Makefile.am
diff options
context:
space:
mode:
authorIan Romanick <[email protected]>2013-10-15 14:01:03 -0700
committerIan Romanick <[email protected]>2013-10-22 15:23:30 -0700
commit09ceed75872e15b175e362f8d0ea146a8c79ae08 (patch)
treee168240b3abf179e21fdd7142705940ac6fa9c90 /src/mesa/main/tests/Makefile.am
parent98b359bd1b469af3b025a8fab5446aac8ce4c727 (diff)
mesa/tests: Add simple, dumb test for _mesa_program_state_string
After some discussions about the correct way to update _mesa_program_state_string, I decided to make a unit test for the function. It turns out that the function didn't work quite the way I thought. The unit test proves that the code was already correct. Signed-off-by: Ian Romanick <[email protected]> Reviewed-by: Kenneth Graunke <[email protected]> Cc: Anuj Phogat <[email protected]>
Diffstat (limited to 'src/mesa/main/tests/Makefile.am')
-rw-r--r--src/mesa/main/tests/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/mesa/main/tests/Makefile.am b/src/mesa/main/tests/Makefile.am
index 87262d52aa0..97713f2c38e 100644
--- a/src/mesa/main/tests/Makefile.am
+++ b/src/mesa/main/tests/Makefile.am
@@ -26,7 +26,8 @@ if HAVE_SHARED_GLAPI
AM_CPPFLAGS += -DHAVE_SHARED_GLAPI
main_test_SOURCES += \
- dispatch_sanity.cpp
+ dispatch_sanity.cpp \
+ program_state_string.cpp
main_test_LDADD += \
$(top_builddir)/src/mapi/shared-glapi/libglapi.la