summaryrefslogtreecommitdiffstats
path: root/src/mesa/main/tests/Makefile.am
diff options
context:
space:
mode:
authorKenneth Graunke <[email protected]>2014-02-25 01:08:45 -0800
committerJason Ekstrand <[email protected]>2014-08-04 11:07:05 -0700
commit72e55bb6888ff4d6b69b10d9c58573e4c3d492ec (patch)
tree9084fd3c939f545bbc0d6a214564755bca9745cb /src/mesa/main/tests/Makefile.am
parent1e0da6233be6e5fb0143615d5e3d3642ddb7964f (diff)
util: Move the open-addressing linear-probing hash_table to src/util.
This hash table is used in core Mesa, the GLSL compiler, and the i965 driver, which makes it a good candidate for the new src/util module. It's much faster than program/hash_table.[ch] (see commit 6991c2922f5 for data), and José's u_hash_table.c has a comment saying Gallium should probably consider switching to a linear probing hash table at some point. So this seems like the best candidate for a shared data structure. Signed-off-by: Kenneth Graunke <[email protected]> v2 (Jason Ekstrand): Pick up another hash_table use and patch up scons Signed-off-by: Jason Ekstrand <[email protected]> Reviewed-by: Marek Olšák <[email protected]>
Diffstat (limited to 'src/mesa/main/tests/Makefile.am')
-rw-r--r--src/mesa/main/tests/Makefile.am2
1 files changed, 0 insertions, 2 deletions
diff --git a/src/mesa/main/tests/Makefile.am b/src/mesa/main/tests/Makefile.am
index 3c7c1b51ad8..251474d5c25 100644
--- a/src/mesa/main/tests/Makefile.am
+++ b/src/mesa/main/tests/Makefile.am
@@ -1,5 +1,3 @@
-SUBDIRS = hash_table
-
AM_CFLAGS = \
$(X11_CFLAGS) \
$(PTHREAD_CFLAGS)