summaryrefslogtreecommitdiffstats
path: root/src/mesa/main/tests/Makefile.am
diff options
context:
space:
mode:
authorIan Romanick <[email protected]>2012-08-01 22:15:12 -0700
committerIan Romanick <[email protected]>2012-09-28 08:19:54 -0700
commit9c59d11cd29e5ddb678824738299d452b4147e0e (patch)
tree9ac33ecaec49ae1eb53fd4c987e37fe6ada63264 /src/mesa/main/tests/Makefile.am
parent6c01a0e770432eda0e29dbd7278a94efc688a6d3 (diff)
mesa/tests: Move stub function to a separate file
When building with shared-glapi, we can just use Mesa's _mesa_warning without problems. stubs.cpp is only used when shared-glapi is not used. Signed-off-by: Ian Romanick <[email protected]>
Diffstat (limited to 'src/mesa/main/tests/Makefile.am')
-rw-r--r--src/mesa/main/tests/Makefile.am14
1 files changed, 12 insertions, 2 deletions
diff --git a/src/mesa/main/tests/Makefile.am b/src/mesa/main/tests/Makefile.am
index 74e02a8ccca..3d1a5d8923f 100644
--- a/src/mesa/main/tests/Makefile.am
+++ b/src/mesa/main/tests/Makefile.am
@@ -3,7 +3,7 @@ AM_CPPFLAGS = \
-I$(top_builddir)/src/mapi \
-I$(top_builddir)/src/mesa \
-I$(top_builddir)/include \
- $(X11_CFLAGS)
+ $(API_DEFINES) $(DEFINES) $(INCLUDE_DIRS)
TESTS = main-test
check_PROGRAMS = main-test
@@ -14,4 +14,14 @@ main_test_SOURCES = \
main_test_LDADD = \
$(top_builddir)/src/mesa/libmesa.la \
$(top_builddir)/src/gtest/libgtest.la \
- -lpthread
+ -lpthread -ldl
+
+if HAVE_SHARED_GLAPI
+AM_CPPFLAGS += -DHAVE_SHARED_GLAPI
+
+main_test_LDADD += \
+ $(top_builddir)/src/mapi/shared-glapi/libglapi.la
+else
+main_test_SOURCES += \
+ stubs.cpp
+endif