summaryrefslogtreecommitdiffstats
path: root/src/mesa/main/tests/Makefile.am
diff options
context:
space:
mode:
authorNanley Chery <[email protected]>2015-08-18 12:42:57 -0700
committerNanley Chery <[email protected]>2015-08-25 15:45:13 -0700
commit8e581747d2342950ff44488064eef53768b3ae82 (patch)
treedab342b9dde865a36b6e09e724dec95f0ca62283 /src/mesa/main/tests/Makefile.am
parent1bec29d04d970b4d60a8c60252313f25bebfe024 (diff)
mesa/formats: make format testing a gtest
We currently check that our format info table is sane during context initialization in debug builds. Perform this check during `make check` instead. This enables format testing in release builds and removes the requirement of an exhuastive switch for _mesa_uncompressed_format_to_type_and_comps(). v2. indentation and conditional inclusion fixes (Chad). allow tests to continue running if any format fails and display the failing format name. Reviewed-by: Chad Versace <[email protected]> Signed-off-by: Nanley Chery <[email protected]>
Diffstat (limited to 'src/mesa/main/tests/Makefile.am')
-rw-r--r--src/mesa/main/tests/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/mesa/main/tests/Makefile.am b/src/mesa/main/tests/Makefile.am
index 251474d5c25..9467f3ba8c6 100644
--- a/src/mesa/main/tests/Makefile.am
+++ b/src/mesa/main/tests/Makefile.am
@@ -27,6 +27,7 @@ AM_CPPFLAGS += -DHAVE_SHARED_GLAPI
main_test_SOURCES += \
dispatch_sanity.cpp \
+ mesa_formats.cpp \
program_state_string.cpp
main_test_LDADD += \