summaryrefslogtreecommitdiffstats
path: root/src/mesa/main/tests/Makefile.am
diff options
context:
space:
mode:
authorKenneth Graunke <[email protected]>2014-02-24 23:39:14 -0800
committerJason Ekstrand <[email protected]>2014-08-04 11:06:58 -0700
commit1e0da6233be6e5fb0143615d5e3d3642ddb7964f (patch)
treeb33478332a051d4d587009cc8a76b71c5210bdc6 /src/mesa/main/tests/Makefile.am
parentdcc29c18b4affd0a69202a822ffe77d94594f98b (diff)
util: Move ralloc to a new src/util directory.
For a long time, we've wanted a place to put utility code which isn't directly tied to Mesa or Gallium internals. This patch creates a new src/util directory for exactly that purpose, and builds the contents as libmesautil.la. ralloc seemed like a good first candidate. These days, it's directly used by mesa/main, i965, i915, and r300g, so keeping it in src/glsl didn't make much sense. Signed-off-by: Kenneth Graunke <[email protected]> v2 (Jason Ekstrand): More realloc uses and some scons fixes Signed-off-by: Jason Ekstrand <[email protected]> Reviewed-by: Marek Olšák <[email protected]>
Diffstat (limited to 'src/mesa/main/tests/Makefile.am')
-rw-r--r--src/mesa/main/tests/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/mesa/main/tests/Makefile.am b/src/mesa/main/tests/Makefile.am
index 0d3a51f3962..3c7c1b51ad8 100644
--- a/src/mesa/main/tests/Makefile.am
+++ b/src/mesa/main/tests/Makefile.am
@@ -5,6 +5,7 @@ AM_CFLAGS = \
$(PTHREAD_CFLAGS)
AM_CPPFLAGS = \
-I$(top_srcdir)/src/gtest/include \
+ -I$(top_srcdir)/src \
-I$(top_srcdir)/src/mapi \
-I$(top_srcdir)/src/mesa \
-I$(top_builddir)/src/mesa \