summaryrefslogtreecommitdiffstats
path: root/src/mesa/drivers/x11/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2014-03-13 05:44:33 +0000
committerEmil Velikov <[email protected]>2014-03-31 13:09:23 +0100
commitd187a150d45cbf5bd3476eab49be5057382c2c86 (patch)
tree21d55b22990122812b5875f31cc1d09966fedc39 /src/mesa/drivers/x11/Makefile.am
parent902dc61f886c0d719ce25894bbc8032ede0f409b (diff)
automake: add -Wl,--no-undefined to all libraries
... apart from the dri drivers. With this final change we can build mesa without fear that the resulting libraries will have unresolved symbols. Signed-off-by: Emil Velikov <[email protected]> Reviewed-by: Matt Turner <[email protected]>
Diffstat (limited to 'src/mesa/drivers/x11/Makefile.am')
-rw-r--r--src/mesa/drivers/x11/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/mesa/drivers/x11/Makefile.am b/src/mesa/drivers/x11/Makefile.am
index 27343d15791..4c63d59a57c 100644
--- a/src/mesa/drivers/x11/Makefile.am
+++ b/src/mesa/drivers/x11/Makefile.am
@@ -62,7 +62,8 @@ lib@GL_LIB@_la_LIBADD = \
$(GL_LIB_DEPS)
lib@GL_LIB@_la_LDFLAGS = \
+ -no-undefined \
-version-number $(GL_MAJOR):$(GL_MINOR):$(GL_PATCH) \
- -no-undefined
+ -Wl,--no-undefined
include $(top_srcdir)/install-lib-links.mk