summaryrefslogtreecommitdiffstats
path: root/src/mesa/drivers/x11/Makefile.am
diff options
context:
space:
mode:
authorMatt Turner <[email protected]>2012-08-22 11:51:31 -0700
committerMatt Turner <[email protected]>2012-08-24 11:08:19 -0700
commitdf4dccc7a9691555e05c8945048603621340b5d7 (patch)
treeaef93e5e2e9a72e1f267477fd2be0e608cf9ac49 /src/mesa/drivers/x11/Makefile.am
parentc56b57f4a124b218aec21e6a53cd6b5ae1718054 (diff)
build: Only add links to .so files if we're building them
Xlib-GLX and OSMesa support static building. Fixes: https://bugs.freedesktop.org/show_bug.cgi?id=53962
Diffstat (limited to 'src/mesa/drivers/x11/Makefile.am')
-rw-r--r--src/mesa/drivers/x11/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/mesa/drivers/x11/Makefile.am b/src/mesa/drivers/x11/Makefile.am
index dab4d6bec8f..2b0a163dc5a 100644
--- a/src/mesa/drivers/x11/Makefile.am
+++ b/src/mesa/drivers/x11/Makefile.am
@@ -65,9 +65,11 @@ lib@GL_LIB@_la_LDFLAGS = \
-no-undefined \
$(GL_LIB_DEPS)
+if BUILD_SHARED
# Provide compatibility with scripts for the old Mesa build system for
# a while by putting a link to the driver into /lib of the build tree.
all-local: lib@[email protected]
$(MKDIR_P) $(top_builddir)/$(LIB_DIR);
ln -f .libs/lib@[email protected].$(GL_MAJOR).$(GL_MINOR).$(GL_PATCH) $(top_builddir)/$(LIB_DIR)/lib@[email protected].$(GL_MAJOR)
ln -sf lib@[email protected].$(GL_MAJOR) $(top_builddir)/$(LIB_DIR)/lib@[email protected]
+endif