summaryrefslogtreecommitdiffstats
path: root/src/mesa/drivers/osmesa/Makefile.am
diff options
context:
space:
mode:
authorJon TURNEY <[email protected]>2012-06-28 23:15:48 +0100
committerJon TURNEY <[email protected]>2012-07-13 12:43:41 +0100
commit68e04cc6014bf7a2c9bd0b3b783b4ec12aa2e824 (patch)
tree41ca584f01c57b781d41d703f044f4452ba4e644 /src/mesa/drivers/osmesa/Makefile.am
parent284325d97b3049e59e64daf784e2b3858f0ffcf5 (diff)
automake: convert libglsl
v2: Use AM_V_GEN to silence generated code rules. Add BUILT_SOURCES to CLEANFILES v3: - Fix an accidental // in a path - Use automake make rules for lex/yacc rather than writing our own - Update .gitignore appropriately - Build a libglcpp convenience library rather than awkwardly including the files in libglsl and delegating the generation - Remove libglsl.a compatibility link on clean v4: - Automake's rules for lex/yacc make .cc if source is .ll or .yy, and apparently we must use those extensions "because of scons", so update everywhere glsl_parser.cpp -> glsl_parser.cc and glsl_lexer.cpp -> glsl_lexer.cc. This fixes 'make tarballs' and building with dricore enabled. Signed-off-by: Jon TURNEY <[email protected]> Reviewed-by: Eric Anholt <[email protected]> Tested-by: Matt Turner <[email protected]>
Diffstat (limited to 'src/mesa/drivers/osmesa/Makefile.am')
-rw-r--r--src/mesa/drivers/osmesa/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/mesa/drivers/osmesa/Makefile.am b/src/mesa/drivers/osmesa/Makefile.am
index 3cf3005071a..2c4ce2c33d2 100644
--- a/src/mesa/drivers/osmesa/Makefile.am
+++ b/src/mesa/drivers/osmesa/Makefile.am
@@ -41,7 +41,7 @@ lib@OSMESA_LIB@_la_LDFLAGS = -module -version-number @OSMESA_VERSION@ -shared
lib@OSMESA_LIB@_la_LIBADD = \
$(top_builddir)/src/mesa/libmesa.a \
$(top_builddir)/src/mapi/glapi/libglapi.a \
- $(top_builddir)/src/glsl/libglsl.a
+ $(top_builddir)/src/glsl/libglsl.la
# Provide compatibility with scripts for the old Mesa build system for
# a while by putting a link to the driver into /lib of the build tree.