summaryrefslogtreecommitdiffstats
path: root/src/mesa/drivers/osmesa/Makefile.am
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2017-10-23 16:09:15 -0700
committerDylan Baker <[email protected]>2017-10-27 11:06:07 -0700
commit5daed06da2c0aaa48a93439bfdb63818786bc278 (patch)
tree5e6d6792cfd41177784fbb7722fde66fc034936f /src/mesa/drivers/osmesa/Makefile.am
parent06c667556045bd9542ad5e6a318f42dd66707bd4 (diff)
osmesa: Include generated headers without path
This makes things much easier to ensure correctness with meson. Tested with make dist-check and with meson. Signed-off-by: Dylan Baker <[email protected]> Reviewed-by: Eric Engestrom <[email protected]>
Diffstat (limited to 'src/mesa/drivers/osmesa/Makefile.am')
-rw-r--r--src/mesa/drivers/osmesa/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/mesa/drivers/osmesa/Makefile.am b/src/mesa/drivers/osmesa/Makefile.am
index 2c8d4668b1b..3c7def5c5c9 100644
--- a/src/mesa/drivers/osmesa/Makefile.am
+++ b/src/mesa/drivers/osmesa/Makefile.am
@@ -30,6 +30,8 @@ AM_CPPFLAGS = \
-I$(top_srcdir)/src/gallium/auxiliary \
-I$(top_builddir)/src/mapi \
-I$(top_srcdir)/src/mapi \
+ -I$(top_builddir)/src/mapi/glapi \
+ -I$(top_srcdir)/src/mapi/glapi \
-I$(top_srcdir)/src/mesa/ \
$(DEFINES)
AM_CFLAGS = $(PTHREAD_CFLAGS) \