summaryrefslogtreecommitdiffstats
path: root/src/mesa/drivers/dri/swrast/Makefile.am
diff options
context:
space:
mode:
authorEric Anholt <[email protected]>2013-09-27 16:57:11 -0700
committerEric Anholt <[email protected]>2013-10-24 14:13:09 -0700
commitbdcee13ca374e4dd72c46951cb137b4f60a6303f (patch)
tree20b8b41ebd4e2b4ba82436c89f4f910bd41fffe7 /src/mesa/drivers/dri/swrast/Makefile.am
parent86d50c2f1567eebd193ac797a49c58c969646787 (diff)
swrast: Build the driver into the shared mesa_dri_drivers.so.
v2: drop dridir now that it's unused. v3: Fix linking after rebase when building just swrast from classic but a drm-using gallium driver. v4: Consistently put spaces around += in the updated Makefile.am block. v5: Set a global driverAPI variable so loaders don't have to update to createNewScreen2() (though they may want to for thread safety). Reviewed-by: Matt Turner <[email protected]> (v3) Reviewed-by: Emil Velikov <[email protected]>
Diffstat (limited to 'src/mesa/drivers/dri/swrast/Makefile.am')
-rw-r--r--src/mesa/drivers/dri/swrast/Makefile.am18
1 files changed, 2 insertions, 16 deletions
diff --git a/src/mesa/drivers/dri/swrast/Makefile.am b/src/mesa/drivers/dri/swrast/Makefile.am
index c51ad2d874b..0837b4518ff 100644
--- a/src/mesa/drivers/dri/swrast/Makefile.am
+++ b/src/mesa/drivers/dri/swrast/Makefile.am
@@ -34,19 +34,5 @@ AM_CFLAGS = \
$(DEFINES) \
$(VISIBILITY_CFLAGS)
-dridir = $(DRI_DRIVER_INSTALL_DIR)
-dri_LTLIBRARIES = swrast_dri.la
-
-swrast_dri_la_SOURCES = \
- $(SWRAST_C_FILES)
-
-swrast_dri_la_LDFLAGS = $(DRI_DRIVER_LDFLAGS)
-
-swrast_dri_la_LIBADD = \
- $(DRI_LIB_DEPS)
-
-# Provide compatibility with scripts for the old Mesa build system for
-# a while by putting a link to the driver into /lib of the build tree.
-all-local: swrast_dri.la
- $(MKDIR_P) $(top_builddir)/$(LIB_DIR);
- ln -f .libs/swrast_dri.so $(top_builddir)/$(LIB_DIR)/swrast_dri.so;
+noinst_LTLIBRARIES = libswrast_dri.la
+libswrast_dri_la_SOURCES = $(SWRAST_C_FILES)