aboutsummaryrefslogtreecommitdiffstats
path: root/src/mesa/drivers/dri/nouveau/Makefile.am
diff options
context:
space:
mode:
authorMatt Turner <[email protected]>2012-10-01 13:00:18 -0700
committerMatt Turner <[email protected]>2012-10-03 13:41:09 -0700
commit31ab61cac10bf75210134b6d8a354ac3cbd3b4da (patch)
tree5c83b24f296935a55466b7188e1780ac0890de93 /src/mesa/drivers/dri/nouveau/Makefile.am
parent551c991606e543c3a264a762026f11348b37947e (diff)
dri drivers: Link dricommon before dynamic libraries
I think libtool should be handling this for us, but the build fails for Jordan because libdricommon (a static library, which uses expat) appears before -lexpat on the linker command. Reviewed-by: Jordan Justen <[email protected]> Tested-by: Jordan Justen <[email protected]>
Diffstat (limited to 'src/mesa/drivers/dri/nouveau/Makefile.am')
-rw-r--r--src/mesa/drivers/dri/nouveau/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/mesa/drivers/dri/nouveau/Makefile.am b/src/mesa/drivers/dri/nouveau/Makefile.am
index a1c20684b4c..8bfbf92ad18 100644
--- a/src/mesa/drivers/dri/nouveau/Makefile.am
+++ b/src/mesa/drivers/dri/nouveau/Makefile.am
@@ -48,9 +48,9 @@ nouveau_vieux_dri_la_SOURCES = \
nouveau_vieux_dri_la_LDFLAGS = -module -avoid-version -shared
nouveau_vieux_dri_la_LIBADD = \
+ ../common/libdricommon.la \
$(DRI_LIB_DEPS) \
- $(NOUVEAU_LIBS) \
- ../common/libdricommon.la
+ $(NOUVEAU_LIBS)
# Provide compatibility with scripts for the old Mesa build system for
# a while by putting a link to the driver into /lib of the build tree.