summaryrefslogtreecommitdiffstats
path: root/src/mesa/drivers/dri/nouveau/Makefile.am
diff options
context:
space:
mode:
authorMatt Turner <[email protected]>2012-10-01 13:00:18 -0700
committerMatt Turner <[email protected]>2012-10-03 13:46:03 -0700
commit89e76252ca3fd015544f76d0f528babe9c723938 (patch)
tree516666b56a29f94d662ee04e0c430b119ad5cf11 /src/mesa/drivers/dri/nouveau/Makefile.am
parentf2b4f588f5a5b656843b720f59b8cd6ce573ac93 (diff)
dri drivers: Link dricommon before dynamic libraries
I think libtool should be handling this for us, but the build fails for Jordan because libdricommon (a static library, which uses expat) appears before -lexpat on the linker command. Reviewed-by: Jordan Justen <[email protected]> Tested-by: Jordan Justen <[email protected]> (cherry picked from commit 31ab61cac10bf75210134b6d8a354ac3cbd3b4da) Conflicts: src/mesa/drivers/dri/i965/Makefile.am
Diffstat (limited to 'src/mesa/drivers/dri/nouveau/Makefile.am')
-rw-r--r--src/mesa/drivers/dri/nouveau/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/mesa/drivers/dri/nouveau/Makefile.am b/src/mesa/drivers/dri/nouveau/Makefile.am
index 82d3804f838..4589b0575a9 100644
--- a/src/mesa/drivers/dri/nouveau/Makefile.am
+++ b/src/mesa/drivers/dri/nouveau/Makefile.am
@@ -47,9 +47,9 @@ nouveau_vieux_dri_la_SOURCES = \
nouveau_vieux_dri_la_LDFLAGS = -module -avoid-version -shared
nouveau_vieux_dri_la_LIBADD = \
+ ../common/libdricommon.la \
$(DRI_LIB_DEPS) \
- $(NOUVEAU_LIBS) \
- ../common/libdricommon.la
+ $(NOUVEAU_LIBS)
# Provide compatibility with scripts for the old Mesa build system for
# a while by putting a link to the driver into /lib of the build tree.