aboutsummaryrefslogtreecommitdiffstats
path: root/src/mesa/drivers/dri/i965/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <[email protected]>2019-05-22 16:37:10 +0100
committerEric Engestrom <[email protected]>2019-06-27 17:42:25 +0000
commit53f17c4efdcded0283087ccc9777b31010db2fec (patch)
tree0e7aee26152fd66c076821024e47f07886c03d00 /src/mesa/drivers/dri/i965/meson.build
parentad0ee5bfa5b9cd6c0e867443b44f98079ff7e7ec (diff)
meson: set up a proper internal dependency for xmlconfig
Signed-off-by: Eric Engestrom <[email protected]> Reviewed-by: Dylan Baker <[email protected]>
Diffstat (limited to 'src/mesa/drivers/dri/i965/meson.build')
-rw-r--r--src/mesa/drivers/dri/i965/meson.build6
1 files changed, 3 insertions, 3 deletions
diff --git a/src/mesa/drivers/dri/i965/meson.build b/src/mesa/drivers/dri/i965/meson.build
index 04b477db58b..3c507126f08 100644
--- a/src/mesa/drivers/dri/i965/meson.build
+++ b/src/mesa/drivers/dri/i965/meson.build
@@ -150,9 +150,9 @@ endforeach
libi965 = static_library(
'i965',
- [files_i965, ir_expression_operation_h, xmlpool_options_h],
+ [files_i965, ir_expression_operation_h],
include_directories : [
- inc_common, inc_intel, inc_dri_common, inc_util, inc_include,
+ inc_common, inc_intel, inc_dri_common, inc_include,
],
c_args : [c_vis_args, no_override_init_args, c_sse2_args],
cpp_args : [cpp_vis_args, c_sse2_args],
@@ -160,5 +160,5 @@ libi965 = static_library(
i965_gen_libs, libintel_common, libintel_dev, libisl, libintel_compiler,
libblorp, libintel_perf
],
- dependencies : [dep_libdrm, dep_valgrind, idep_nir_headers, idep_genxml],
+ dependencies : [dep_libdrm, dep_valgrind, idep_nir_headers, idep_genxml, idep_xmlconfig],
)