summaryrefslogtreecommitdiffstats
path: root/src/mesa/drivers/dri/i965/meson.build
diff options
context:
space:
mode:
authorKenneth Graunke <[email protected]>2016-06-18 23:05:51 -0700
committerKenneth Graunke <[email protected]>2018-02-16 10:48:10 -0800
commit1d6cf433d2d0dfa3edd9eaaed1e8c961bbd22f99 (patch)
treee219c9514c0929c059c7de6f6baf119bfd673fe7 /src/mesa/drivers/dri/i965/meson.build
parent9bcd31ea90addd7a16802de8a28b2f3242dc8298 (diff)
i965: Implement GenerateMipmap directly, rather than using Meta.
Meta is awful and we'd like to stop using it. Implementing this using BLORP allows us to stop trashing a bunch of GL state every time. This follows the structure of st_generate_mipmap(). compute_num_levels is lifted directly from there. Improves performance in Gl41HdrBloom by about 11.794% +/- 1.01919% (n=3) on Kabylake GT2 at 1280x720 (the difference seems much smaller at higher resolutions). v2 (idr): Don't try depth or depth-stencil blorp blits on Gen4 or Gen5 because it's not implemented yet. Signed-off-by: Ian Romanick <[email protected]> Reviewed-by: Topi Pohjolainen <[email protected]>
Diffstat (limited to 'src/mesa/drivers/dri/i965/meson.build')
-rw-r--r--src/mesa/drivers/dri/i965/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/mesa/drivers/dri/i965/meson.build b/src/mesa/drivers/dri/i965/meson.build
index 24a69132114..e6866147d9f 100644
--- a/src/mesa/drivers/dri/i965/meson.build
+++ b/src/mesa/drivers/dri/i965/meson.build
@@ -42,6 +42,7 @@ files_i965 = files(
'brw_ff_gs_emit.c',
'brw_ff_gs.h',
'brw_formatquery.c',
+ 'brw_generate_mipmap.c',
'brw_gs.c',
'brw_gs.h',
'brw_gs_surface_state.c',