summaryrefslogtreecommitdiffstats
path: root/src/mesa/drivers/dri/i965/Makefile.am
diff options
context:
space:
mode:
authorMatt Turner <[email protected]>2016-11-04 22:34:53 -0700
committerMatt Turner <[email protected]>2017-01-20 11:40:52 -0800
commitf0429359cc8a9d5bdc1f76f2107bf1df151b123c (patch)
treea38e6d1d5a6acabb7239f1cee6956d6163fc6465 /src/mesa/drivers/dri/i965/Makefile.am
parentae9c69e1cfd34597e8f8b9f724c62aadfec5b13f (diff)
i965: Add a test for the EU assembly validator.
Reviewed-by: Kenneth Graunke <[email protected]>
Diffstat (limited to 'src/mesa/drivers/dri/i965/Makefile.am')
-rw-r--r--src/mesa/drivers/dri/i965/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/mesa/drivers/dri/i965/Makefile.am b/src/mesa/drivers/dri/i965/Makefile.am
index 4b009770ab9..2e22d65b91d 100644
--- a/src/mesa/drivers/dri/i965/Makefile.am
+++ b/src/mesa/drivers/dri/i965/Makefile.am
@@ -109,6 +109,7 @@ TESTS = \
test_fs_copy_propagation \
test_fs_saturate_propagation \
test_eu_compact \
+ test_eu_validate \
test_vf_float_conversions \
test_vec4_cmod_propagation \
test_vec4_copy_propagation \
@@ -162,3 +163,9 @@ test_eu_compact_SOURCES = \
test_eu_compact.c
nodist_EXTRA_test_eu_compact_SOURCES = dummy.cpp
test_eu_compact_LDADD = $(TEST_LIBS)
+
+test_eu_validate_SOURCES = \
+ test_eu_validate.cpp
+test_eu_validate_LDADD = \
+ $(top_builddir)/src/gtest/libgtest.la \
+ $(TEST_LIBS)