summaryrefslogtreecommitdiffstats
path: root/src/mesa/drivers/dri/i965/Makefile.am
diff options
context:
space:
mode:
authorRobert Bragg <[email protected]>2015-11-25 16:41:04 +0000
committerLionel Landwerlin <[email protected]>2017-06-27 14:10:29 +0300
commit1fc7b951278428bd0fbbe040226737a44742f353 (patch)
treeffa4365c166418c196e82e91d4bcf87c76120c57 /src/mesa/drivers/dri/i965/Makefile.am
parent243909d41efd266f2c4817bbe968c9ad558df160 (diff)
i965: Add Gen8+ INTEL_performance_query support
Enables access to OA unit metrics on Gen8+ via INTEL_performance_query. v2: make use of new parameters coming from gen_device_info (Lionel) Signed-off-by: Robert Bragg <[email protected]> Signed-off-by: Lionel Landwerlin <[email protected]> Reviewed-by: Kenneth Graunke <[email protected]>
Diffstat (limited to 'src/mesa/drivers/dri/i965/Makefile.am')
-rw-r--r--src/mesa/drivers/dri/i965/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/src/mesa/drivers/dri/i965/Makefile.am b/src/mesa/drivers/dri/i965/Makefile.am
index 03cfe12b193..3e09fef2d21 100644
--- a/src/mesa/drivers/dri/i965/Makefile.am
+++ b/src/mesa/drivers/dri/i965/Makefile.am
@@ -116,7 +116,7 @@ EXTRA_DIST = \
# .c and .h files in one go so we don't hit problems with parallel
# make and multiple invocations of the same script trying to write
# to the same files.
-brw_oa_hsw.h: brw_oa.py brw_oa_hsw.xml
- $(PYTHON2) $(PYTHON_FLAGS) $(srcdir)/brw_oa.py --header=$(builddir)/brw_oa_hsw.h --chipset=hsw $(srcdir)/brw_oa_hsw.xml
-brw_oa_hsw.c: brw_oa.py brw_oa_hsw.xml
- $(PYTHON2) $(PYTHON_FLAGS) $(srcdir)/brw_oa.py --code=$(builddir)/brw_oa_hsw.c --chipset=hsw $(srcdir)/brw_oa_hsw.xml
+brw_oa_%.h: brw_oa.py brw_oa_%.xml Makefile.am
+ $(PYTHON2) $(PYTHON_FLAGS) $(srcdir)/brw_oa.py --header=$(builddir)/brw_oa_$(*).h --chipset=$(*) $(srcdir)/brw_oa_$(*).xml
+brw_oa_%.c: brw_oa.py brw_oa_%.xml Makefile.am
+ $(PYTHON2) $(PYTHON_FLAGS) $(srcdir)/brw_oa.py --code=$(builddir)/brw_oa_$(*).c --chipset=$(*) $(srcdir)/brw_oa_$(*).xml