summaryrefslogtreecommitdiffstats
path: root/src/mesa/drivers/dri/i965/Makefile.am
diff options
context:
space:
mode:
authorJason Ekstrand <[email protected]>2017-02-28 09:10:43 -0800
committerEmil Velikov <[email protected]>2017-03-13 11:16:34 +0000
commit700bebb958e93f4d472c383de62ced9db8e64bec (patch)
tree0075c098c56c338f38ba0db80b9dba3e7e268a17 /src/mesa/drivers/dri/i965/Makefile.am
parentd0d4a5f43b4dd79bd7bfff7c7deaade10bfebf7c (diff)
i965: Move the back-end compiler to src/intel/compiler
Mostly a dummy git mv with a couple of noticable parts: - With the earlier header cleanups, nothing in src/intel depends files from src/mesa/drivers/dri/i965/ - Both Autoconf and Android builds are addressed. Thanks to Mauro and Tapani for the fixups in the latter - brw_util.[ch] is not really compiler specific, so it's moved to i965. v2: - move brw_eu_defines.h instead of brw_defines.h - remove no-longer applicable includes - add missing vulkan/ prefix in the Android build (thanks Tapani) v3: - don't list brw_defines.h in src/intel/Makefile.sources (Jason) - rebase on top of the oa patches [Emil Velikov: commit message, various small fixes througout] Signed-off-by: Emil Velikov <[email protected]> Reviewed-by: Jason Ekstrand <[email protected]>
Diffstat (limited to 'src/mesa/drivers/dri/i965/Makefile.am')
-rw-r--r--src/mesa/drivers/dri/i965/Makefile.am94
1 files changed, 3 insertions, 91 deletions
diff --git a/src/mesa/drivers/dri/i965/Makefile.am b/src/mesa/drivers/dri/i965/Makefile.am
index 9e922ac41fd..a83e3a6fa16 100644
--- a/src/mesa/drivers/dri/i965/Makefile.am
+++ b/src/mesa/drivers/dri/i965/Makefile.am
@@ -44,11 +44,6 @@ AM_CFLAGS = \
AM_CXXFLAGS = $(AM_CFLAGS)
-MKDIR_GEN = $(AM_V_at)$(MKDIR_P) $(@D)
-brw_nir_trig_workarounds.c: brw_nir_trig_workarounds.py $(top_srcdir)/src/compiler/nir/nir_algebraic.py
- $(MKDIR_GEN)
- $(AM_V_GEN) PYTHONPATH=$(top_srcdir)/src/compiler/nir $(PYTHON2) $(PYTHON_FLAGS) $(srcdir)/brw_nir_trig_workarounds.py > $@ || ($(RM) $@; false)
-
I965_PERGEN_LIBS = \
libi965_gen6.la \
libi965_gen7.la \
@@ -73,7 +68,6 @@ libi965_gen9_la_CFLAGS = $(AM_CFLAGS) -DGEN_VERSIONx10=90
noinst_LTLIBRARIES = \
libi965_dri.la \
- libi965_compiler.la \
$(I965_PERGEN_LIBS)
libi965_dri_la_SOURCES = \
@@ -82,101 +76,18 @@ libi965_dri_la_SOURCES = \
libi965_dri_la_LIBADD = \
$(top_builddir)/src/intel/common/libintel_common.la \
$(top_builddir)/src/intel/isl/libisl.la \
- libi965_compiler.la \
+ $(top_builddir)/src/intel/compiler/libintel_compiler.la \
$(top_builddir)/src/intel/blorp/libblorp.la \
$(I965_PERGEN_LIBS) \
$(INTEL_LIBS)
-libi965_compiler_la_SOURCES = \
- $(i965_compiler_FILES) \
- $(i965_compiler_GENERATED_FILES)
-
-BUILT_SOURCES = $(i965_compiler_GENERATED_FILES)
+BUILT_SOURCES = $(i965_oa_GENERATED_FILES)
CLEANFILES = $(BUILT_SOURCES)
EXTRA_DIST = \
- brw_nir_trig_workarounds.py \
brw_oa_hsw.xml \
brw_oa.py
-TEST_LIBS = \
- libi965_compiler.la \
- $(I965_PERGEN_LIBS) \
- $(top_builddir)/src/intel/common/libintel_common.la \
- $(top_builddir)/src/compiler/nir/libnir.la \
- $(top_builddir)/src/util/libmesautil.la \
- $(top_builddir)/src/intel/isl/libisl.la \
- $(PTHREAD_LIBS) \
- $(DLOPEN_LIBS)
-
-TESTS = \
- test_fs_cmod_propagation \
- test_fs_copy_propagation \
- test_fs_saturate_propagation \
- test_eu_compact \
- test_eu_validate \
- test_vf_float_conversions \
- test_vec4_cmod_propagation \
- test_vec4_copy_propagation \
- test_vec4_register_coalesce
-
-check_PROGRAMS = $(TESTS)
-
-test_fs_cmod_propagation_SOURCES = \
- test_fs_cmod_propagation.cpp
-test_fs_cmod_propagation_LDADD = \
- $(top_builddir)/src/gtest/libgtest.la \
- $(TEST_LIBS)
-
-test_fs_copy_propagation_SOURCES = \
- test_fs_copy_propagation.cpp
-test_fs_copy_propagation_LDADD = \
- $(top_builddir)/src/gtest/libgtest.la \
- $(TEST_LIBS)
-
-test_fs_saturate_propagation_SOURCES = \
- test_fs_saturate_propagation.cpp
-test_fs_saturate_propagation_LDADD = \
- $(top_builddir)/src/gtest/libgtest.la \
- $(TEST_LIBS)
-
-test_vf_float_conversions_SOURCES = \
- test_vf_float_conversions.cpp
-test_vf_float_conversions_LDADD = \
- $(top_builddir)/src/gtest/libgtest.la \
- $(TEST_LIBS)
-
-test_vec4_register_coalesce_SOURCES = \
- test_vec4_register_coalesce.cpp
-test_vec4_register_coalesce_LDADD = \
- $(top_builddir)/src/gtest/libgtest.la \
- $(TEST_LIBS)
-
-test_vec4_copy_propagation_SOURCES = \
- test_vec4_copy_propagation.cpp
-test_vec4_copy_propagation_LDADD = \
- $(top_builddir)/src/gtest/libgtest.la \
- $(TEST_LIBS)
-
-test_vec4_cmod_propagation_SOURCES = \
- test_vec4_cmod_propagation.cpp
-test_vec4_cmod_propagation_LDADD = \
- $(top_builddir)/src/gtest/libgtest.la \
- $(TEST_LIBS)
-
-test_eu_compact_SOURCES = \
- test_eu_compact.c
-nodist_EXTRA_test_eu_compact_SOURCES = dummy.cpp
-test_eu_compact_LDADD = $(TEST_LIBS)
-
-test_eu_validate_SOURCES = \
- test_eu_validate.cpp
-test_eu_validate_LDADD = \
- $(top_builddir)/src/gtest/libgtest.la \
- $(TEST_LIBS)
-
-BUILT_SOURCES += $(i965_oa_GENERATED_FILES)
-
# Note: we avoid using a multi target rule here and outputting both the
# .c and .h files in one go so we don't hit problems with parallel
# make and multiple invocations of the same script trying to write
@@ -185,3 +96,4 @@ brw_oa_%.h: brw_oa_%.xml brw_oa.py Makefile.am
$(PYTHON2) $(PYTHON_FLAGS) $(srcdir)/brw_oa.py --header=$(builddir)/brw_oa_$(*).h --chipset="$(*)" $(srcdir)/brw_oa_$(*).xml
brw_oa_%.c: brw_oa_%.xml brw_oa.py Makefile.am
$(PYTHON2) $(PYTHON_FLAGS) $(srcdir)/brw_oa.py --code=$(builddir)/brw_oa_$(*).c --chipset="$(*)" $(srcdir)/brw_oa_$(*).xml
+