summaryrefslogtreecommitdiffstats
path: root/src/mesa/drivers/dri/i965/Makefile.am
diff options
context:
space:
mode:
authorEric Anholt <[email protected]>2012-11-30 23:52:38 -0800
committerEric Anholt <[email protected]>2012-12-14 16:06:01 -0800
commita76a03f437df3c6458da5b0e9e70fd4d986fbdae (patch)
tree9bd66959f920da48248dabafb9f2aef9a7b53f1b /src/mesa/drivers/dri/i965/Makefile.am
parent7171c45d3a6392b947d96c10362ce0459b741669 (diff)
i965/vs: Add a unit test for opt_compute_to_mrf().
The compute-to-mrf code is really twitchy, and it's hard to construct GLSL testcases for it. This unit test is also really hard to work with (for example, if your instruction is removed by dead code elimination, you end up inspecting something irrelevant), but I did use it for debugging some of the commits to follow. I called it test_vec4_register_coalesce because the compute-to-mrf code is about to morph into that. Reviewed-by: Kenneth Graunke <[email protected]>
Diffstat (limited to 'src/mesa/drivers/dri/i965/Makefile.am')
-rw-r--r--src/mesa/drivers/dri/i965/Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/src/mesa/drivers/dri/i965/Makefile.am b/src/mesa/drivers/dri/i965/Makefile.am
index f5ca12b581b..8e96467b211 100644
--- a/src/mesa/drivers/dri/i965/Makefile.am
+++ b/src/mesa/drivers/dri/i965/Makefile.am
@@ -66,8 +66,14 @@ i965_dri_la_SOURCES =
i965_dri_la_LIBADD = $(COMMON_LIBS)
i965_dri_la_LDFLAGS = -module -avoid-version -shared
-TESTS = test_eu_compact
-check_PROGRAMS = test_eu_compact
+TESTS = \
+ test_eu_compact \
+ test_vec4_register_coalesce
+check_PROGRAMS = $(TESTS)
+
+test_vec4_register_coalesce_LDADD = \
+ $(TEST_LIBS) \
+ $(top_builddir)/src/gtest/libgtest.la
test_eu_compact_SOURCES = \
test_eu_compact.c