summaryrefslogtreecommitdiffstats
path: root/src/mesa/drivers/dri/i965/Makefile.am
diff options
context:
space:
mode:
authorKristian Høgsberg Kristensen <[email protected]>2015-10-06 16:54:52 -0700
committerKristian Høgsberg Kristensen <[email protected]>2015-10-08 12:15:03 -0700
commit08d890d3bb82eb1f5c71cf2eab1521c20c4d154c (patch)
tree08e6ffd7337cae0cd3e0d9d7ebea157fb5edd45d /src/mesa/drivers/dri/i965/Makefile.am
parent9a2573e5fc63f48cde56efdb191c129e7d7fb7b1 (diff)
i965: Break out backend compiler to its own library
This introduces a new libtool helper library, libi965_compiler.la. This library is moderately self-contained, but still needs to link to all of libmesa.la among other things. Reviewed-by: Jason Ekstrand <[email protected]> Signed-off-by: Kristian Høgsberg Kristensen <[email protected]>
Diffstat (limited to 'src/mesa/drivers/dri/i965/Makefile.am')
-rw-r--r--src/mesa/drivers/dri/i965/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/mesa/drivers/dri/i965/Makefile.am b/src/mesa/drivers/dri/i965/Makefile.am
index 566f2ddd98f..82e58a6baa8 100644
--- a/src/mesa/drivers/dri/i965/Makefile.am
+++ b/src/mesa/drivers/dri/i965/Makefile.am
@@ -41,9 +41,11 @@ AM_CFLAGS = \
AM_CXXFLAGS = $(AM_CFLAGS)
-noinst_LTLIBRARIES = libi965_dri.la
+noinst_LTLIBRARIES = libi965_dri.la libi965_compiler.la
libi965_dri_la_SOURCES = $(i965_FILES)
-libi965_dri_la_LIBADD = $(INTEL_LIBS)
+libi965_dri_la_LIBADD = libi965_compiler.la $(INTEL_LIBS)
+
+libi965_compiler_la_SOURCES = $(i965_compiler_FILES)
TEST_LIBS = \
libi965_dri.la \