summaryrefslogtreecommitdiffstats
path: root/src/mesa/drivers/dri/i915/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2013-09-17 15:58:29 +0100
committerTom Stellard <[email protected]>2013-10-01 07:29:49 -0700
commite11ff60e280083829a23cff7120eb932e26d0832 (patch)
treeedb032b63286ce4dd1cad21759da3db1c024d1c4 /src/mesa/drivers/dri/i915/Makefile.am
parentcb1febb074ca5a9d4674c953106b467f175c4c0f (diff)
mesa/drivers: drop HAVE_*_DRI from individual makefiles
The mesa/drivers/dri/Makefile.am already guards the individual targets/subdirs with HAVE_*_DRI before including them. Thus making the additional check within each Makefile.am unnecessary. Signed-off-by: Emil Velikov <[email protected]> Reviewed-by: Kenneth Graunke <[email protected]>
Diffstat (limited to 'src/mesa/drivers/dri/i915/Makefile.am')
-rw-r--r--src/mesa/drivers/dri/i915/Makefile.am3
1 files changed, 0 insertions, 3 deletions
diff --git a/src/mesa/drivers/dri/i915/Makefile.am b/src/mesa/drivers/dri/i915/Makefile.am
index 46dd4c27756..b07ad138798 100644
--- a/src/mesa/drivers/dri/i915/Makefile.am
+++ b/src/mesa/drivers/dri/i915/Makefile.am
@@ -36,10 +36,7 @@ AM_CFLAGS = \
$(INTEL_CFLAGS)
dridir = $(DRI_DRIVER_INSTALL_DIR)
-
-if HAVE_I915_DRI
dri_LTLIBRARIES = i915_dri.la
-endif
i915_dri_la_SOURCES = $(i915_FILES)
i915_dri_la_LDFLAGS = $(DRI_DRIVER_LDFLAGS)