summaryrefslogtreecommitdiffstats
path: root/src/mesa/drivers/dri/i915/Makefile.am
diff options
context:
space:
mode:
authorEric Anholt <[email protected]>2012-01-25 14:40:41 -0800
committerEric Anholt <[email protected]>2012-01-26 16:14:22 -0800
commit45389caf0583fafbc56340fc66008382db4df950 (patch)
tree9dfd7fd06e945dd7f5490d9838eb6f655fc82071 /src/mesa/drivers/dri/i915/Makefile.am
parent29ea1c44612b25806e71d55b88e7e8385af940a6 (diff)
dri: Move the compile of the common files to a convenience library.
Reviewed-by: Matt Turner <[email protected]>
Diffstat (limited to 'src/mesa/drivers/dri/i915/Makefile.am')
-rw-r--r--src/mesa/drivers/dri/i915/Makefile.am13
1 files changed, 3 insertions, 10 deletions
diff --git a/src/mesa/drivers/dri/i915/Makefile.am b/src/mesa/drivers/dri/i915/Makefile.am
index 5c44a9e7dc0..bcfde69d700 100644
--- a/src/mesa/drivers/dri/i915/Makefile.am
+++ b/src/mesa/drivers/dri/i915/Makefile.am
@@ -46,23 +46,16 @@ if HAVE_I915_DRI
dri_LTLIBRARIES = i915_dri.la
endif
-# These should be an ltlibrary that's built once. Let's fix that once
-# the other drivers are converted to automake.
-COMMON_FILES = \
- ../common/utils.c \
- ../common/dri_util.c \
- ../common/xmlconfig.c
-
i915_dri_la_SOURCES = \
$(i915_C_FILES) \
- $(i915_CXX_FILES) \
- $(COMMON_FILES)
+ $(i915_CXX_FILES)
i915_dri_la_LDFLAGS = -module -avoid-version -shared
i915_dri_la_LIBADD = \
$(DRI_LIB_DEPS) \
$(DRICORE_LIB_DEPS) \
- $(INTEL_LIBS)
+ $(INTEL_LIBS) \
+ ../common/libdricommon.la
# Provide compatibility with scripts for the old Mesa build system for
# a while by putting a link to the driver into /lib of the build tree.