summaryrefslogtreecommitdiffstats
path: root/src/mesa/SConscript
diff options
context:
space:
mode:
authorJason Ekstrand <[email protected]>2014-08-22 09:49:09 -0700
committerIago Toral Quiroga <[email protected]>2015-01-12 11:20:28 +0100
commite1fdcddafe95ca8a62fc86c8219de459fcbd219e (patch)
treee8aab8e1c024c7b65bd5cdaa6d6a09122a79051f /src/mesa/SConscript
parente0439f750557bc6880a8a4eccb38256fafd63fae (diff)
mesa: Autogenerate format_unpack.c
Signed-off-by: Jason Ekstrand <[email protected]> v2 by Samuel Iglesias <[email protected]>: - Add usage of INDENT_FLAGS in Makefile.am v3 by Samuel Iglesias <[email protected]>: - Modify unpack_float_*() and unpack_ubyte_*() function generation to use c.datatype() and f.datatype() - Fix out-of-tree build v4 by Samuel Iglesias <[email protected]>: - format_unpack.c.mako is now format_unpack.py, with the template code inlined. It now auto-generates format_unpack.c - Add format_unpack.c to gitignore. - Simplify Makefile.am change - Modify SConscript to build format_unpack.c with scons v5 by Samuel Iglesias <[email protected]>: - Don't allow float to non-normalized integer format conversions. Signed-off-by: Samuel Iglesias Gonsalvez <[email protected]> Reviewed-by: Jason Ekstrand <[email protected]>
Diffstat (limited to 'src/mesa/SConscript')
-rw-r--r--src/mesa/SConscript7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/mesa/SConscript b/src/mesa/SConscript
index d9a34784048..1ad5f26d8bb 100644
--- a/src/mesa/SConscript
+++ b/src/mesa/SConscript
@@ -73,6 +73,13 @@ format_pack = env.CodeGenerate(
command = python_cmd + ' $SCRIPT ' + ' $SOURCE > $TARGET'
)
+format_unpack = env.CodeGenerate(
+ target = 'main/format_unpack.c',
+ script = 'main/format_unpack.py',
+ source = 'main/formats.csv',
+ command = python_cmd + ' $SCRIPT ' + ' $SOURCE > $TARGET'
+)
+
#
# Assembly sources
#