aboutsummaryrefslogtreecommitdiffstats
path: root/src/mesa/Makefile.am
diff options
context:
space:
mode:
authorVadim Girlin <[email protected]>2012-08-24 11:16:14 +0400
committerVadim Girlin <[email protected]>2012-08-24 11:16:14 +0400
commite84d45fdb73687019a6798cfb37b01291b212f4d (patch)
treea89c651276970f2814ca52b96ce08b4276566556 /src/mesa/Makefile.am
parent1434a86f50e4ffc69316c7e948ebfe56a25d31da (diff)
build: don't leave git_sha1.h.tmp after build/install
Fixes "`main/git_sha1.h.tmp': Permission denied" build error. See https://bugs.freedesktop.org/show_bug.cgi?id=52064 Signed-off-by: Vadim Girlin <[email protected]> Reviewed-by: Eric Anholt <[email protected]>
Diffstat (limited to 'src/mesa/Makefile.am')
-rw-r--r--src/mesa/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/mesa/Makefile.am b/src/mesa/Makefile.am
index 3b5ef24c0ed..1ac64e64df2 100644
--- a/src/mesa/Makefile.am
+++ b/src/mesa/Makefile.am
@@ -39,6 +39,8 @@ main/git_sha1.h: main/git_sha1.h.tmp
@echo "updating main/git_sha1.h"
@if ! cmp -s main/git_sha1.h.tmp main/git_sha1.h; then \
mv main/git_sha1.h.tmp main/git_sha1.h ;\
+ else \
+ rm main/git_sha1.h.tmp ;\
fi
# include glapi_gen.mk for generating glapi headers for GLES