aboutsummaryrefslogtreecommitdiffstats
path: root/src/mesa/Makefile.am
diff options
context:
space:
mode:
authorEric Anholt <[email protected]>2012-11-07 16:33:39 -0800
committerChad Versace <[email protected]>2012-11-12 15:52:42 -0800
commit907844107252260c646aca361191ef7f121f3d23 (patch)
treecf9a5a54b804e852344541a096992943687e2a6a /src/mesa/Makefile.am
parent0ef85357479a47c2bdd05df3b2183bc7bfa0ac6e (diff)
automake,android: Build program/ into a helper lib (v2)
While simplifying mesa/Makefile.am, the more important feature of this commit is allowing a file with the same name to appear in both main/ and program/. v2: [chadv] Add changes to Android makefiles. Reviewed-by: Kenneth Graunke <[email protected]> (v1) Signed-off-by: Chad Versace <[email protected]> (v2)
Diffstat (limited to 'src/mesa/Makefile.am')
-rw-r--r--src/mesa/Makefile.am26
1 files changed, 11 insertions, 15 deletions
diff --git a/src/mesa/Makefile.am b/src/mesa/Makefile.am
index 34e8c82fdb1..9809ee437cc 100644
--- a/src/mesa/Makefile.am
+++ b/src/mesa/Makefile.am
@@ -23,7 +23,7 @@ if NEED_LIBDRICORE
DRICORE_SUBDIR = libdricore
endif
-SUBDIRS = x86 x86-64 . $(DRICORE_SUBDIR) drivers
+SUBDIRS = program x86 x86-64 . $(DRICORE_SUBDIR) drivers
gldir = $(includedir)/GL
gl_HEADERS = $(top_srcdir)/include/GL/*.h
@@ -53,22 +53,11 @@ include $(GLAPI)/glapi_gen.mk
BUILT_SOURCES = \
main/git_sha1.h \
- main/get_hash.h \
- program/program_parse.tab.c \
- program/program_parse.tab.h \
- program/lex.yy.c
+ main/get_hash.h
CLEANFILES = \
$(BUILT_SOURCES) \
git_sha1.h.tmp
-program/program_parse.tab.c program/program_parse.tab.h: program/program_parse.y
- $(MKDIR_P) program
- $(AM_V_GEN) $(YACC) -p "_mesa_program_" -v -d --output=program/program_parse.tab.c $<
-
-program/lex.yy.c: program/program_lexer.l
- $(MKDIR_P) program
- $(AM_V_GEN) $(LEX) --never-interactive --outfile=$@ $<
-
GET_HASH_GEN = main/get_hash_generator.py
GET_HASH_GEN_FLAGS := $(patsubst -DFEATURE_%=1,-a %, \
$(patsubst -DFEATURE_%=0,,$(API_DEFINES)))
@@ -124,14 +113,21 @@ libmesa_la_SOURCES = \
$(MESA_FILES) \
$(MESA_ASM_FILES_FOR_ARCH)
-libmesa_la_LIBADD = $(top_builddir)/src/glsl/libglsl.la
+libmesa_la_LIBADD = \
+ $(top_builddir)/src/glsl/libglsl.la \
+ $(top_builddir)/src/mesa/program/libprogram.la \
+ $()
libmesa_la_LDFLAGS =
libmesagallium_la_SOURCES = \
$(MESA_GALLIUM_FILES) \
$(MESA_ASM_FILES_FOR_ARCH)
-libmesagallium_la_LIBADD = $(top_builddir)/src/glsl/libglsl.la
+libmesagallium_la_LIBADD = \
+ $(top_builddir)/src/glsl/libglsl.la \
+ $(top_builddir)/src/mesa/program/libprogram.la \
+ $()
+
libmesagallium_la_LDFLAGS =
if HAVE_GALLIUM