aboutsummaryrefslogtreecommitdiffstats
path: root/src/mesa/Makefile.am
diff options
context:
space:
mode:
authorMatt Turner <[email protected]>2012-08-21 22:26:52 -0700
committerMatt Turner <[email protected]>2012-08-24 11:08:19 -0700
commit8cdce6c136799aa75310086c078d8cd5f19b84ce (patch)
tree357f65d39569b38b9e1736b4794bf96c7e3c2653 /src/mesa/Makefile.am
parent00f3d9b11acd366329c347e4797b8af3437fcfe6 (diff)
build: Only build libmesa.la when needed
Namely, for Xlib-GLX, OSMesa, or test programs.
Diffstat (limited to 'src/mesa/Makefile.am')
-rw-r--r--src/mesa/Makefile.am12
1 files changed, 8 insertions, 4 deletions
diff --git a/src/mesa/Makefile.am b/src/mesa/Makefile.am
index 1ac64e64df2..6964c8a68ab 100644
--- a/src/mesa/Makefile.am
+++ b/src/mesa/Makefile.am
@@ -94,7 +94,12 @@ program/lex.yy.c: program/program_lexer.l
$(MKDIR_P) program
$(AM_V_GEN) $(LEX) --never-interactive --outfile=$@ $<
-noinst_LTLIBRARIES = libmesa.la
+noinst_LTLIBRARIES =
+if NEED_LIBMESA
+noinst_LTLIBRARIES += libmesa.la
+else
+check_LTLIBRARIES = libmesa.la
+endif
if HAVE_GALLIUM
noinst_LTLIBRARIES += libmesagallium.la
endif
@@ -145,15 +150,14 @@ libmesagallium_la_SOURCES = \
libmesagallium_la_LIBADD = $(top_builddir)/src/glsl/libglsl.la
libmesagallium_la_LDFLAGS =
+if HAVE_GALLIUM
# Provide compatibility with scripts for the old Mesa build system for
# a while by putting a link to the library in the current directory.
all-local: $(noinst_LTLIBRARIES)
- ln -f .libs/libmesa.a .
-if HAVE_GALLIUM
ln -f .libs/libmesagallium.a .
endif
-CLEANFILES += libmesa.a libmesagallium.a
+CLEANFILES += libmesagallium.a
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = gl.pc