summaryrefslogtreecommitdiffstats
path: root/src/mesa/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2018-08-16 13:59:38 +0100
committerEmil Velikov <[email protected]>2018-08-23 17:00:13 +0100
commitae7898dfdbe5c8dab7d11c71862353f1ae43feb0 (patch)
treedf2e6bbf52a4a9450f1306bf8344b049eb1fb71e /src/mesa/Makefile.am
parentc51e7486d90a605b18109d5509fed0d3db23a8a5 (diff)
configure: allow building with python3
Pretty much all of the scripts are python2+3 compatible. Check and allow using python3, while adjusting the PYTHON2 refs. Note: - python3.4 is used as it's the earliest supported version - python3 chosen prior to python2 Signed-off-by: Emil Velikov <[email protected]> Acked-by: Eric Engestrom <[email protected]>
Diffstat (limited to 'src/mesa/Makefile.am')
-rw-r--r--src/mesa/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/mesa/Makefile.am b/src/mesa/Makefile.am
index 195e4400355..d7daa995c5c 100644
--- a/src/mesa/Makefile.am
+++ b/src/mesa/Makefile.am
@@ -73,7 +73,7 @@ CLEANFILES = \
$(BUILT_SOURCES) \
program/program_parse.tab.h
-PYTHON_GEN = $(AM_V_GEN)$(PYTHON2) $(PYTHON_FLAGS)
+PYTHON_GEN = $(AM_V_GEN)$(PYTHON) $(PYTHON_FLAGS)
main/get_hash.h: ../mapi/glapi/gen/gl_and_es_API.xml main/get_hash_params.py \
main/get_hash_generator.py