summaryrefslogtreecommitdiffstats
path: root/src/mesa/Makefile.am
diff options
context:
space:
mode:
authorMatt Turner <[email protected]>2012-09-20 15:08:02 -0700
committerMatt Turner <[email protected]>2012-10-01 15:23:05 -0700
commit523c01524638b3d1bb363f4c0a647b0777840b7a (patch)
tree4d6b56383239919045adbd38f029a88dcbedfa21 /src/mesa/Makefile.am
parentb6c0fa1280c523eb5c75d5508cd18d5ae7c8b21c (diff)
build: Don't build libdricore if not building classic drivers
Diffstat (limited to 'src/mesa/Makefile.am')
-rw-r--r--src/mesa/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/mesa/Makefile.am b/src/mesa/Makefile.am
index a76df8c306a..feec1070da1 100644
--- a/src/mesa/Makefile.am
+++ b/src/mesa/Makefile.am
@@ -19,7 +19,11 @@
# FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS
# IN THE SOFTWARE.
-SUBDIRS = x86 x86-64 . libdricore drivers
+if NEED_LIBDRICORE
+DRICORE_SUBDIR = libdricore
+endif
+
+SUBDIRS = x86 x86-64 . $(DRICORE_SUBDIR) drivers
gldir = $(includedir)/GL
gl_HEADERS = $(top_srcdir)/include/GL/*.h