summaryrefslogtreecommitdiffstats
path: root/src/mesa/Makefile.am
diff options
context:
space:
mode:
authorJon TURNEY <[email protected]>2014-05-12 10:17:06 +0100
committerJon TURNEY <[email protected]>2014-05-23 15:24:04 +0100
commit45f9aae004f7bd723c3f313ee3dd8a25aa420ffa (patch)
tree1dc94055f8be1c6bfbc8671c914cea2f0c5d1681 /src/mesa/Makefile.am
parentff90a8784cf22ada7bba75f90460b063818abda7 (diff)
Make DRI dependencies and build depend on the target
- Don't require xcb-dri[23] etc. if we aren't building for a target with DRM, as we won't be using dri[23] - Enable a more fine-grained control of what DRI code is built, so that a libGL using direct swrast can be built on targets which don't have DRM. The HAVE_DRI automake conditional is retired in favour of a number of other conditionals: HAVE_DRI2 enables building of code using the DRI2 interface (and possibly DRI3 with HAVE_DRI3) HAVE_DRISW enables building of DRI swrast HAVE_DRICOMMON enables building of target-independent DRI code, and also enables some makefile cases where a more detailled decision is made at a lower level. HAVE_APPLEDRI enables building of an Apple-specific direct rendering interface, still which requires additional fixing up to build properly. v2: Place xfont.c and drisw_glx.c into correct categories. Update 'make check' as well Signed-off-by: Jon TURNEY <[email protected]> Reviewed-by: Jeremy Huddleston Sequoia <[email protected]> Reviewed-by: Emil Velikov <[email protected]>
Diffstat (limited to 'src/mesa/Makefile.am')
-rw-r--r--src/mesa/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/mesa/Makefile.am b/src/mesa/Makefile.am
index 0fdc8f3150c..88eeff9ee50 100644
--- a/src/mesa/Makefile.am
+++ b/src/mesa/Makefile.am
@@ -25,7 +25,7 @@ if HAVE_X11_DRIVER
SUBDIRS += drivers/x11
endif
-if HAVE_DRI
+if HAVE_DRICOMMON
SUBDIRS += drivers/dri
endif