summaryrefslogtreecommitdiffstats
path: root/src/mesa/Makefile.am
diff options
context:
space:
mode:
authorJason Ekstrand <[email protected]>2014-06-20 15:52:10 -0700
committerJason Ekstrand <[email protected]>2014-08-05 10:56:15 -0700
commit12610ffcf79b20996f16fec4cbed1c1e2ef67f5e (patch)
tree47cb4bdf5f923588fd1cdcff007b0bfa5ae0581f /src/mesa/Makefile.am
parent342056531053bf929cb9f0e24e2121ffa52c80b2 (diff)
mesa/formats: Autogenerate the format_info structure from a CSV file
Instead of a having all of the format metadata in a gigantic hard-to-edit array of type struct format_info, we now have a human-readable CSV file. The CSV file also contains more format information than the format_info struct contained so we can potentially make format_info more detailed later. The python to generate the format information was added the previous commit. This commit turns it on in both automake and scons builds. v2: Split into two commits and stuff to generate format_info.c from scons Signed-off-by: Jason Ekstrand <[email protected]> Reviewed-by: Brian Paul <[email protected]>
Diffstat (limited to 'src/mesa/Makefile.am')
-rw-r--r--src/mesa/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/src/mesa/Makefile.am b/src/mesa/Makefile.am
index 88eeff9ee50..57c1e4a579d 100644
--- a/src/mesa/Makefile.am
+++ b/src/mesa/Makefile.am
@@ -64,6 +64,7 @@ include Makefile.sources
BUILT_SOURCES = \
main/get_hash.h \
+ main/format_info.c \
$(BUILDDIR)main/git_sha1.h \
$(BUILDDIR)program/program_parse.tab.c \
$(BUILDDIR)program/lex.yy.c
@@ -81,6 +82,15 @@ main/get_hash.h: $(GLAPI)/gl_and_es_API.xml main/get_hash_params.py \
-f $< > [email protected]; \
+main/format_info.c: main/formats.csv \
+ main/format_parser.py main/format_info.py
+ $(AM_V_GEN)set -e; \
+ $(PYTHON2) $(PYTHON_FLAGS) $(srcdir)/main/format_info.py \
+
+main/formats.c: main/format_info.c
+
noinst_LTLIBRARIES = $(ARCH_LIBS)
if NEED_LIBMESA
noinst_LTLIBRARIES += libmesa.la