summaryrefslogtreecommitdiffstats
path: root/src/mesa/Makefile.am
diff options
context:
space:
mode:
authorLauri Kasanen <[email protected]>2013-12-19 21:43:25 +0200
committerMatt Turner <[email protected]>2013-12-20 17:00:57 -0800
commitfcefdc9a595c52ade2be15e0f3a2f301fee3599c (patch)
tree199c8e9cd69b7dd3b389a1839ad4668d78fc5f48 /src/mesa/Makefile.am
parent79f268978d2341205f03738a2bc981838c09d920 (diff)
mesa: Fix build to properly check for supported compiler flags
Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=72708 Reviewed-by: Matt Turner <[email protected]> Signed-off-by: Lauri Kasanen <[email protected]>
Diffstat (limited to 'src/mesa/Makefile.am')
-rw-r--r--src/mesa/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/mesa/Makefile.am b/src/mesa/Makefile.am
index a60600e0364..884383652d3 100644
--- a/src/mesa/Makefile.am
+++ b/src/mesa/Makefile.am
@@ -103,7 +103,11 @@ noinst_PROGRAMS = gen_matypes
gen_matypes_SOURCES = x86/gen_matypes.c
BUILT_SOURCES += matypes.h
-ARCH_LIBS = libmesa_sse41.la
+ARCH_LIBS =
+
+if SSE41_SUPPORTED
+ARCH_LIBS += libmesa_sse41.la
+endif
if HAVE_X86_64_ASM
MESA_ASM_FILES_FOR_ARCH += $(X86_64_FILES)