summaryrefslogtreecommitdiffstats
path: root/src/mesa/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2014-08-31 23:16:15 +0100
committerEmil Velikov <[email protected]>2014-09-01 00:22:20 +0100
commit88cbe3908f0ea08228a5ffb1808f98b6906c4416 (patch)
treee33ba09f17894f9c79015acd70e95465a7c54b2a /src/mesa/Makefile.am
parent5598458e69232dcab9500717edbbf88085223529 (diff)
mesa: fix make tarballs
Current method of generating distribution tar-balls involves manually invoking make + target name in the appropriate places. This temporary solution is used until we get 'make dist' working. Currently it does not work, as in order to have the target (which is also a filename) available in the final Makefile we need to add a PHONY target + use the correct target name. Cc: "10.2 10.3" <[email protected]> Signed-off-by: Emil Velikov <[email protected]>
Diffstat (limited to 'src/mesa/Makefile.am')
-rw-r--r--src/mesa/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/mesa/Makefile.am b/src/mesa/Makefile.am
index e71bccbbe64..b23208ae815 100644
--- a/src/mesa/Makefile.am
+++ b/src/mesa/Makefile.am
@@ -36,7 +36,8 @@ endif
gldir = $(includedir)/GL
gl_HEADERS = $(top_srcdir)/include/GL/*.h
-.PHONY: $(BUILDDIR)main/git_sha1.h.tmp
+.PHONY: $(BUILDDIR)main/git_sha1.h.tmp $(BUILDDIR)program/lex.yy.c $(BUILDDIR)program/program_parse.tab.c $(BUILDDIR)program/program_parse.tab.h
+
$(BUILDDIR)main/git_sha1.h.tmp:
@touch main/git_sha1.h.tmp
@if test -d $(top_srcdir)/.git; then \