summaryrefslogtreecommitdiffstats
path: root/src/mesa/Makefile.am
diff options
context:
space:
mode:
authorMatt Turner <[email protected]>2012-09-05 21:08:39 -0700
committerAndreas Boll <[email protected]>2013-01-13 00:55:37 +0100
commit92ce9c38fd5e2260ca2a707548c4de13a6002a1b (patch)
tree9896c99928b93d2c1eee28bc09b1a97907ce85c8 /src/mesa/Makefile.am
parent8c80bdc4a8d0b1c39cad8b8bfb1b982a498f0a8e (diff)
Remove hacks for static Makefiles
v2: Andreas Boll <[email protected]> - don't remove compatibility with scripts for the old build system v3: Andreas Boll <[email protected]> - remove more obsolete hacks v4: Andreas Boll <[email protected]> - add a previously removed TOP variable to fix vgapi build
Diffstat (limited to 'src/mesa/Makefile.am')
-rw-r--r--src/mesa/Makefile.am13
1 files changed, 1 insertions, 12 deletions
diff --git a/src/mesa/Makefile.am b/src/mesa/Makefile.am
index 9809ee437cc..41483dd63e8 100644
--- a/src/mesa/Makefile.am
+++ b/src/mesa/Makefile.am
@@ -128,20 +128,9 @@ libmesagallium_la_LIBADD = \
$(top_builddir)/src/mesa/program/libprogram.la \
$()
-libmesagallium_la_LDFLAGS =
-
-if HAVE_GALLIUM
-# Provide compatibility with scripts for the old Mesa build system for
-# a while by putting a link to the library in the current directory.
-all-local: $(noinst_LTLIBRARIES)
- ln -f .libs/libmesagallium.a .
-endif
-
-CLEANFILES += libmesagallium.a
-
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = gl.pc
# Emacs tags
tags:
- etags `find . -name \*.[ch]` $(TOP)/include/GL/*.h
+ etags `find . -name \*.[ch]` $(top_srcdir)/include/GL/*.h