summaryrefslogtreecommitdiffstats
path: root/src/mesa/Makefile.am
diff options
context:
space:
mode:
authorBrian Paul <[email protected]>2013-04-17 09:49:39 -0600
committerBrian Paul <[email protected]>2013-04-17 17:33:40 -0600
commit815ca0bf38de89cff533a413066a7e23a0aa5fb0 (patch)
tree46589e04f080897905809da8d014ca5e94a82eeb /src/mesa/Makefile.am
parent9835d9059683e285dc925801c4c98ea9bfc2ffb8 (diff)
mesa: generate glGetInteger/Boolean/Float/Doublev() code for all APIs
No longer pass -a flag to the get_hash_generate.py script to specify OpenGL, ES1, ES2, etc. This updates the autoconf, scons and android build files too (so we can bisect). This is the last of the API-dependent conditional compilation in core Mesa. Reviewed-by: Jordan Justen <[email protected]>
Diffstat (limited to 'src/mesa/Makefile.am')
-rw-r--r--src/mesa/Makefile.am6
1 files changed, 2 insertions, 4 deletions
diff --git a/src/mesa/Makefile.am b/src/mesa/Makefile.am
index 5850412aa4b..2d077f865da 100644
--- a/src/mesa/Makefile.am
+++ b/src/mesa/Makefile.am
@@ -71,14 +71,12 @@ CLEANFILES = \
git_sha1.h.tmp
GET_HASH_GEN = main/get_hash_generator.py
-GET_HASH_GEN_FLAGS := $(patsubst -DFEATURE_%=1,-a %, \
- $(patsubst -DFEATURE_%=0,,$(API_DEFINES)))
main/get_hash.h: $(GLAPI)/gl_and_es_API.xml main/get_hash_params.py \
$(GET_HASH_GEN) Makefile
$(AM_V_GEN)set -e; \
- $(PYTHON2) $(PYTHON_FLAGS) $(srcdir)/$(GET_HASH_GEN) \
- $(GET_HASH_GEN_FLAGS) -f $< > [email protected]; \
+ $(PYTHON2) $(PYTHON_FLAGS) $(srcdir)/$(GET_HASH_GEN) \
+ -f $< > [email protected]; \
noinst_LTLIBRARIES =