summaryrefslogtreecommitdiffstats
path: root/src/mesa/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2015-03-02 15:58:17 +0000
committerEmil Velikov <[email protected]>2015-03-05 14:45:54 +0000
commit3f6c28f2a976e35128b7a4a513cfa60af00301e1 (patch)
treee44a3c52ec55f6ff396e9ca17582c57a18d4003a /src/mesa/Makefile.am
parentabae3434c42ce55d0aa26443e52fea98cc7cfe32 (diff)
mesa: rename format_info.c to format_info.h
The file is auto-generated, and #included by formats.c. Let's rename it to reflect the latter. This will also help up fix the dependency tracking by adding it to the _SOURCES variable, without the side effect of it being compiled (twice). v2: Update .gitignore to reflect the rename. Cc: "10.4, 10.5" <[email protected]> Signed-off-by: Emil Velikov <[email protected]> Reviewed-by: Matt Turner <[email protected]>
Diffstat (limited to 'src/mesa/Makefile.am')
-rw-r--r--src/mesa/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/src/mesa/Makefile.am b/src/mesa/Makefile.am
index 467492f55c1..5f9ee1e25ff 100644
--- a/src/mesa/Makefile.am
+++ b/src/mesa/Makefile.am
@@ -79,7 +79,7 @@ EXTRA_DIST = \
BUILT_SOURCES = \
main/get_hash.h \
- main/format_info.c \
+ main/format_info.h \
main/git_sha1.h \
main/format_pack.c \
main/format_unpack.c \
@@ -99,7 +99,7 @@ main/get_hash.h: ../mapi/glapi/gen/gl_and_es_API.xml main/get_hash_params.py \
-f $< > [email protected]; \
-main/format_info.c: main/formats.csv \
+main/format_info.h: main/formats.csv \
main/format_parser.py main/format_info.py
$(AM_V_GEN)set -e; \
$(PYTHON2) $(PYTHON_FLAGS) $(srcdir)/main/format_info.py \
@@ -122,7 +122,7 @@ main/format_unpack.c: main/format_unpack.py main/formats.csv \
$(srcdir)/main/formats.csv \
| $(INDENT) $(INDENT_FLAGS) > $@;
-main/formats.c: main/format_info.c
+main/formats.c: main/format_info.h
noinst_LTLIBRARIES = $(ARCH_LIBS)
if NEED_LIBMESA