summaryrefslogtreecommitdiffstats
path: root/src/mesa/Makefile.am
diff options
context:
space:
mode:
authorMatt Turner <[email protected]>2013-11-05 13:53:45 -0800
committerMatt Turner <[email protected]>2013-11-07 10:00:25 -0800
commitd8abd6710ea41545ae2fb9b8e718d29a69574b1a (patch)
tree6d001f0f881458b6dc129c17909a6af9f27f1ae0 /src/mesa/Makefile.am
parent957c7570ea3f7d6ea4cf2cc49d85207136fb0470 (diff)
build: Change HAVE_X86_ASM to mean x86 or x86-64 asm.
I want a conditional that says generally "we have x86 assembly" in the next patch. Reviewed-by: Eric Anholt <[email protected]>
Diffstat (limited to 'src/mesa/Makefile.am')
-rw-r--r--src/mesa/Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/src/mesa/Makefile.am b/src/mesa/Makefile.am
index a54b8ac1b30..5f9bae2ac2a 100644
--- a/src/mesa/Makefile.am
+++ b/src/mesa/Makefile.am
@@ -98,12 +98,13 @@ AM_CXXFLAGS = $(LLVM_CFLAGS) $(VISIBILITY_CXXFLAGS)
MESA_ASM_FILES_FOR_ARCH =
if HAVE_X86_ASM
-MESA_ASM_FILES_FOR_ARCH += $(X86_FILES)
-AM_CPPFLAGS += -I$(builddir)/x86 -I$(srcdir)/x86
-endif
if HAVE_X86_64_ASM
MESA_ASM_FILES_FOR_ARCH += $(X86_64_FILES)
AM_CPPFLAGS += -I$(builddir)/x86-64 -I$(srcdir)/x86-64
+else
+MESA_ASM_FILES_FOR_ARCH += $(X86_FILES)
+AM_CPPFLAGS += -I$(builddir)/x86 -I$(srcdir)/x86
+endif
endif
if HAVE_SPARC_ASM
MESA_ASM_FILES_FOR_ARCH += $(SPARC_FILES)