summaryrefslogtreecommitdiffstats
path: root/src/mesa/Makefile.am
diff options
context:
space:
mode:
authorMatt Turner <[email protected]>2012-08-17 15:51:59 -0700
committerMatt Turner <[email protected]>2012-08-22 11:08:06 -0700
commitbfd7d6f58b47984853cf0831057e84a617de25ed (patch)
treecc7387c4977a848744a79b164b525e25b643dcc0 /src/mesa/Makefile.am
parentf9786394e5969593f9a0ea6e5653168197506523 (diff)
build: Only build libmesagallium.la if building Gallium
Reviewed-by: Kenneth Graunke <[email protected]>
Diffstat (limited to 'src/mesa/Makefile.am')
-rw-r--r--src/mesa/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/src/mesa/Makefile.am b/src/mesa/Makefile.am
index f1cd6d67c6e..3b5ef24c0ed 100644
--- a/src/mesa/Makefile.am
+++ b/src/mesa/Makefile.am
@@ -92,7 +92,10 @@ program/lex.yy.c: program/program_lexer.l
$(MKDIR_P) program
$(AM_V_GEN) $(LEX) --never-interactive --outfile=$@ $<
-noinst_LTLIBRARIES = libmesa.la libmesagallium.la
+noinst_LTLIBRARIES = libmesa.la
+if HAVE_GALLIUM
+noinst_LTLIBRARIES += libmesagallium.la
+endif
SRCDIR = $(top_srcdir)/src/mesa/
BUILDDIR = $(top_builddir)/src/mesa/
@@ -142,9 +145,11 @@ libmesagallium_la_LDFLAGS =
# Provide compatibility with scripts for the old Mesa build system for
# a while by putting a link to the library in the current directory.
-all-local: libmesa.la libmesagallium.la
+all-local: $(noinst_LTLIBRARIES)
ln -f .libs/libmesa.a .
+if HAVE_GALLIUM
ln -f .libs/libmesagallium.a .
+endif
CLEANFILES += libmesa.a libmesagallium.a