summaryrefslogtreecommitdiffstats
path: root/src/mesa/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2016-05-30 12:09:04 +0100
committerEmil Velikov <[email protected]>2016-05-30 17:53:45 +0100
commit4cd9cd6abc772388b41ca6e7d85f62e32014120f (patch)
treed2e9725177801540daa51931371cfea1324d0fde /src/mesa/Makefile.am
parent13faddb6b8e30ff0e81e62fb863304a57c712aae (diff)
automake: move the git_sha1.h rule a level up
This way we can reuse the header from other places like - src/intel/vulkan and src/gallium. Only the former is hooked up atm. Make sure .gitignore is updated, as well as all the users (the mesa code does not need any changes). Also ensure that the file is always created by adding it to the BUILT_SOURCES target. Cc: Jason Ekstrand <[email protected]> Cc: Kristian Høgsberg Kristensen <[email protected]> Signed-off-by: Emil Velikov <[email protected]>
Diffstat (limited to 'src/mesa/Makefile.am')
-rw-r--r--src/mesa/Makefile.am26
1 files changed, 1 insertions, 25 deletions
diff --git a/src/mesa/Makefile.am b/src/mesa/Makefile.am
index 2c77fa80a49..6d7a3cc9486 100644
--- a/src/mesa/Makefile.am
+++ b/src/mesa/Makefile.am
@@ -36,28 +36,6 @@ endif
gldir = $(includedir)/GL
gl_HEADERS = $(top_srcdir)/include/GL/*.h
-.PHONY: main/git_sha1.h.tmp
-main/git_sha1.h.tmp:
- @# Don't assume that $(top_srcdir)/.git is a directory. It may be
- @# a gitlink file if $(top_srcdir) is a submodule checkout or a linked
- @# worktree.
- @touch main/git_sha1.h.tmp
- @if test -e $(top_srcdir)/.git; then \
- if which git > /dev/null; then \
- git --git-dir=$(top_srcdir)/.git log -n 1 --oneline | \
- sed 's/^\([^ ]*\) .*/#define MESA_GIT_SHA1 "git-\1"/' \
- > main/git_sha1.h.tmp ; \
- fi \
- fi
-
-main/git_sha1.h: main/git_sha1.h.tmp
- @echo "updating main/git_sha1.h"
- @if ! cmp -s main/git_sha1.h.tmp main/git_sha1.h; then \
- mv main/git_sha1.h.tmp main/git_sha1.h ;\
- else \
- rm main/git_sha1.h.tmp ;\
- fi
-
include Makefile.sources
EXTRA_DIST = \
@@ -80,15 +58,13 @@ EXTRA_DIST = \
BUILT_SOURCES = \
main/get_hash.h \
main/format_info.h \
- main/git_sha1.h \
main/format_pack.c \
main/format_unpack.c \
program/program_parse.tab.c \
program/lex.yy.c
CLEANFILES = \
$(BUILT_SOURCES) \
- program/program_parse.tab.h \
- main/git_sha1.h.tmp
+ program/program_parse.tab.h
PYTHON_GEN = $(AM_V_GEN)$(PYTHON2) $(PYTHON_FLAGS)