summaryrefslogtreecommitdiffstats
path: root/src/mapi/shared-glapi/tests/Makefile.am
diff options
context:
space:
mode:
authorIan Romanick <[email protected]>2012-08-01 14:48:27 -0700
committerIan Romanick <[email protected]>2012-08-08 10:06:26 -0700
commit45d3d0ad2154ccfa0fc1d02c943cefccb5f67b5b (patch)
treef7d3710e44aa560a520ee52166ed2ec27b4e20c1 /src/mapi/shared-glapi/tests/Makefile.am
parentd9f899bb93c4faa202acb8703aad70c5a5b2fcf1 (diff)
mesa/tests: Add tests for the generated shared-glapi dispatch table
These are largely based on the src/mapi/glapi/tests. However, shared-glapi provides less external visibility into the dispatch table, so there is less to test. Also, shared-glapi does not implement _glapi_get_proc_name, so that test was removed. Signed-off-by: Ian Romanick <[email protected]>
Diffstat (limited to 'src/mapi/shared-glapi/tests/Makefile.am')
-rw-r--r--src/mapi/shared-glapi/tests/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/src/mapi/shared-glapi/tests/Makefile.am b/src/mapi/shared-glapi/tests/Makefile.am
new file mode 100644
index 00000000000..49b86afb95a
--- /dev/null
+++ b/src/mapi/shared-glapi/tests/Makefile.am
@@ -0,0 +1,17 @@
+if HAVE_SHARED_GLAPI
+AM_CPPFLAGS = \
+ -I$(top_builddir)/src/gtest/include \
+ -I$(top_builddir)/src/mapi \
+ -I$(top_builddir)/include
+
+TESTS = shared-glapi-test
+check_PROGRAMS = shared-glapi-test
+
+shared_glapi_test_SOURCES = \
+ check_table.cpp
+
+shared_glapi_test_LDADD = \
+ $(top_builddir)/src/mapi/shared-glapi/libglapi.la \
+ $(top_builddir)/src/gtest/libgtest.la \
+ -lpthread
+endif