summaryrefslogtreecommitdiffstats
path: root/src/mapi/glapi/gen/Makefile.am
diff options
context:
space:
mode:
authorPaul Berry <[email protected]>2012-11-07 13:03:13 -0800
committerTimothy Arceri <[email protected]>2017-03-16 14:14:18 +1100
commit05dd4a1104ea815e4627bab0fbd35d9abe49f024 (patch)
tree60ba154ffd5b79821eb7c21373dd2a16d4bc6d96 /src/mapi/glapi/gen/Makefile.am
parentf05524ffaa98488c3faecebe952f1676fbb6a09c (diff)
glapi: Generate GL API marshalling code from the XML.
This is not yet used in the build, just generated. v2: Add missing build dependencies. v3: Avoid mixing declarations and code, remove logic for avoiding emitting code that the compiler's optimizer can deal with anyway. v4: (Timothy Arceri) move safe_mul() genereation here from a later patch. Acked-by: Timothy Arceri <[email protected]> Acked-by: Marek Olšák <[email protected]> Tested-by: Dieter Nützel <[email protected]> Tested-by: Mike Lothian <[email protected]>
Diffstat (limited to 'src/mapi/glapi/gen/Makefile.am')
-rw-r--r--src/mapi/glapi/gen/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/mapi/glapi/gen/Makefile.am b/src/mapi/glapi/gen/Makefile.am
index 079b1bb225e..1375855858f 100644
--- a/src/mapi/glapi/gen/Makefile.am
+++ b/src/mapi/glapi/gen/Makefile.am
@@ -54,6 +54,8 @@ BUILT_SOURCES = \
$(MESA_GLAPI_ASM_OUTPUTS) \
$(MESA_DIR)/main/enums.c \
$(MESA_DIR)/main/api_exec.c \
+ $(MESA_DIR)/main/marshal_generated.c \
+ $(MESA_DIR)/main/marshal_generated.h \
$(MESA_DIR)/main/dispatch.h \
$(MESA_DIR)/main/remap_helper.h \
$(MESA_GLX_DIR)/indirect.c \
@@ -287,6 +289,12 @@ $(MESA_DIR)/main/enums.c: gl_enums.py $(srcdir)/../registry/gl.xml
$(MESA_DIR)/main/api_exec.c: gl_genexec.py apiexec.py $(COMMON)
$(PYTHON_GEN) $(srcdir)/gl_genexec.py -f $(srcdir)/gl_and_es_API.xml > $@
+$(MESA_DIR)/main/marshal_generated.c: gl_marshal.py marshal_XML.py $(COMMON)
+ $(PYTHON_GEN) $< -f $(srcdir)/gl_and_es_API.xml > $@
+
+$(MESA_DIR)/main/marshal_generated.h: gl_marshal_h.py marshal_XML.py $(COMMON)
+ $(PYTHON_GEN) $< -f $(srcdir)/gl_and_es_API.xml > $@
+
$(MESA_DIR)/main/dispatch.h: gl_table.py $(COMMON)
$(PYTHON_GEN) $(srcdir)/gl_table.py -f $(srcdir)/gl_and_es_API.xml -m remap_table > $@