summaryrefslogtreecommitdiffstats
path: root/src/mapi/glapi/gen/Makefile.am
diff options
context:
space:
mode:
authorKristian Høgsberg Kristensen <[email protected]>2016-05-23 22:49:51 -0700
committerKristian Høgsberg Kristensen <[email protected]>2016-05-25 09:41:44 -0700
commit85008db1d51f923113832394d7f8d6b1868be882 (patch)
tree1d033fbf1ecc53d8f0d0699fae9de52cc7965345 /src/mapi/glapi/gen/Makefile.am
parentf036eea2cf3012b6b7f9e1c7b317dd78811a1a3a (diff)
i965: Enable GL_KHR_robustness
GL_KHR_robustness adds the GL_CONTEXT_LOST error and five new entry points that we already implement. This patch adds a new dispatch table that returns GL_CONTEXT_LOST from all entry points and implements the GL_LOSE_CONTEXT_ON_RESET strategy by setting that table when we learn that we've lost the context. With the GL_CONTEXT_LOST reporting in place and dispatch for the new entry points we can turn on GL_KHR_robustness. Signed-off-by: Kristian Høgsberg Kristensen <[email protected]> Reviewed-by: Ian Romanick <[email protected]> Acked-by: Ilia Mirkin <[email protected]>
Diffstat (limited to 'src/mapi/glapi/gen/Makefile.am')
-rw-r--r--src/mapi/glapi/gen/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/mapi/glapi/gen/Makefile.am b/src/mapi/glapi/gen/Makefile.am
index 0759819a4cd..c511de932eb 100644
--- a/src/mapi/glapi/gen/Makefile.am
+++ b/src/mapi/glapi/gen/Makefile.am
@@ -192,6 +192,8 @@ API_XML = \
INTEL_performance_query.xml \
KHR_debug.xml \
KHR_context_flush_control.xml \
+ KHR_robustness.xml \
+ KHR_robustness_es.xml \
KHR_texture_compression_astc.xml \
NV_conditional_render.xml \
NV_primitive_restart.xml \