summaryrefslogtreecommitdiffstats
path: root/src/mapi/glapi/gen/Makefile.am
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2015-05-20 15:49:11 -0700
committerMatt Turner <[email protected]>2015-05-22 11:31:28 -0700
commit9ace0b542241c77ae82a0835ac8a09e2a7510eaf (patch)
treedd1b5e6bba2fe161fa2b6cb8bc9e8d4a75ae14d2 /src/mapi/glapi/gen/Makefile.am
parent1c7cc67778073fd802773390da55980702637547 (diff)
glapi: glX_proto_size.py: use argparse instead of getopt
This is roughly equivalent to the original getopt, except that it removes the '-h' short option, which argparse reserves for auto-generated help messages. It does retain the long option specified by the getopt version, and changes the makefile to use that. Signed-off-by: Dylan Baker <[email protected]> Acked-by: Matt Turner <[email protected]>
Diffstat (limited to 'src/mapi/glapi/gen/Makefile.am')
-rw-r--r--src/mapi/glapi/gen/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/mapi/glapi/gen/Makefile.am b/src/mapi/glapi/gen/Makefile.am
index adebd5c65f6..d7742f7b9d4 100644
--- a/src/mapi/glapi/gen/Makefile.am
+++ b/src/mapi/glapi/gen/Makefile.am
@@ -290,7 +290,7 @@ $(MESA_GLX_DIR)/indirect_init.c: glX_proto_send.py $(COMMON_GLX)
$(MESA_GLX_DIR)/indirect_size.h $(XORG_GLX_DIR)/indirect_size.h: glX_proto_size.py $(COMMON_GLX)
$(PYTHON_GEN) $< -f $(srcdir)/gl_API.xml -m size_h --only-set \
- -h _INDIRECT_SIZE_H_ \
+ --header-tag _INDIRECT_SIZE_H_ \
| $(INDENT) $(INDENT_FLAGS) > $@
$(MESA_GLX_DIR)/indirect_size.c: glX_proto_size.py $(COMMON_GLX)