summaryrefslogtreecommitdiffstats
path: root/src/mapi/glapi/Makefile.am
diff options
context:
space:
mode:
authorMatt Turner <[email protected]>2013-11-05 13:53:45 -0800
committerMatt Turner <[email protected]>2013-11-07 10:00:25 -0800
commitd8abd6710ea41545ae2fb9b8e718d29a69574b1a (patch)
tree6d001f0f881458b6dc129c17909a6af9f27f1ae0 /src/mapi/glapi/Makefile.am
parent957c7570ea3f7d6ea4cf2cc49d85207136fb0470 (diff)
build: Change HAVE_X86_ASM to mean x86 or x86-64 asm.
I want a conditional that says generally "we have x86 assembly" in the next patch. Reviewed-by: Eric Anholt <[email protected]>
Diffstat (limited to 'src/mapi/glapi/Makefile.am')
-rw-r--r--src/mapi/glapi/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/src/mapi/glapi/Makefile.am b/src/mapi/glapi/Makefile.am
index 05c67a6d4b8..bf653a30543 100644
--- a/src/mapi/glapi/Makefile.am
+++ b/src/mapi/glapi/Makefile.am
@@ -33,10 +33,11 @@ AM_CPPFLAGS = \
-I$(top_srcdir)/src/mesa
if HAVE_X86_ASM
-GLAPI_ASM_SOURCES = $(X86_API)
-endif
if HAVE_X86_64_ASM
GLAPI_ASM_SOURCES = $(X86_64_API)
+else
+GLAPI_ASM_SOURCES = $(X86_API)
+endif
endif
if HAVE_SPARC_ASM
GLAPI_ASM_SOURCES = $(SPARC_API)