summaryrefslogtreecommitdiffstats
path: root/src/mapi/es2api/meson.build
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2018-05-17 13:44:30 -0700
committerDylan Baker <[email protected]>2019-05-03 10:58:05 -0700
commitff9bf223c24143260a975f45963eb90f40565c57 (patch)
treec8ec393ae985491da3d8812b36a8be586dbfaaad /src/mapi/es2api/meson.build
parentf5eafc2dc6a68c9c2c2660dff528de1ecdedf4dc (diff)
meson: make nm binary optional
This makes nm not required, but used if found. In general I imagine that this means that on windows nm wont be found, and on other platforms it will. v2: - fix gbm and egl symbols check tests to only be run if nm is found - reword commit message to reflect the code change Reviewed-by: Eric Anholt <[email protected]>
Diffstat (limited to 'src/mapi/es2api/meson.build')
-rw-r--r--src/mapi/es2api/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/mapi/es2api/meson.build b/src/mapi/es2api/meson.build
index 5b2c52b024d..d374bd80849 100644
--- a/src/mapi/es2api/meson.build
+++ b/src/mapi/es2api/meson.build
@@ -52,7 +52,7 @@ pkg.generate(
libraries_private : gl_priv_libs,
)
-if with_tests
+if with_tests and prog_nm.found()
test(
'es2-ABI-check',
find_program('ABI-check'),