summaryrefslogtreecommitdiffstats
path: root/src/mapi/es2api/Makefile.am
diff options
context:
space:
mode:
authorMatt Turner <[email protected]>2013-01-29 17:37:02 -0800
committerMatt Turner <[email protected]>2013-03-19 12:04:32 -0700
commit322c840bea5838782f927a2c1d1711b0d7d50d29 (patch)
tree27e87a18b6535e27b277c57a6e11643e2e3c02f4 /src/mapi/es2api/Makefile.am
parent569bd281c1f5c3b64f4caab2c76611dfa2e6948c (diff)
gles2: Add an ABI-check test
Checks that no functions are exported that are not part of the ABI. Note that currently we are exporting functions that are aliased to functions that are part of the ABI. They shouldn't be exported, but the XML descriptions don't adequately describe this case.
Diffstat (limited to 'src/mapi/es2api/Makefile.am')
-rw-r--r--src/mapi/es2api/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/mapi/es2api/Makefile.am b/src/mapi/es2api/Makefile.am
index 0538f736dfa..9f79536942d 100644
--- a/src/mapi/es2api/Makefile.am
+++ b/src/mapi/es2api/Makefile.am
@@ -28,6 +28,8 @@ AM_CPPFLAGS = \
AM_CFLAGS = $(VISIBILITY_CFLAGS)
+TESTS = ABI-check
+
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = glesv2.pc