summaryrefslogtreecommitdiffstats
path: root/src/mapi/es2api/Makefile.am
diff options
context:
space:
mode:
authorMatt Turner <[email protected]>2012-08-21 14:52:59 -0700
committerMatt Turner <[email protected]>2012-08-23 09:38:32 -0700
commit0f8110cb0c782b179933da0b47649c3f8fe42328 (patch)
tree47f6032a69f9d871016d84d76e463a1a87bec113 /src/mapi/es2api/Makefile.am
parent68d6441930fa19e2414a4c273ddce15e0c71de99 (diff)
automake: convert es2api
Diffstat (limited to 'src/mapi/es2api/Makefile.am')
-rw-r--r--src/mapi/es2api/Makefile.am60
1 files changed, 60 insertions, 0 deletions
diff --git a/src/mapi/es2api/Makefile.am b/src/mapi/es2api/Makefile.am
new file mode 100644
index 00000000000..edd3c9f2c32
--- /dev/null
+++ b/src/mapi/es2api/Makefile.am
@@ -0,0 +1,60 @@
+# Copyright © 2012 Intel Corporation
+#
+# Permission is hereby granted, free of charge, to any person obtaining a
+# copy of this software and associated documentation files (the "Software"),
+# to deal in the Software without restriction, including without limitation
+# the rights to use, copy, modify, merge, publish, distribute, sublicense,
+# and/or sell copies of the Software, and to permit persons to whom the
+# Software is furnished to do so, subject to the following conditions:
+#
+# The above copyright notice and this permission notice (including the next
+# paragraph) shall be included in all copies or substantial portions of the
+# Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
+# THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
+# FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS
+# IN THE SOFTWARE.
+
+AM_CPPFLAGS = \
+ $(DEFINES) \
+ -I$(top_srcdir)/include \
+ -I$(top_srcdir)/src/mapi \
+ -DMAPI_MODE_BRIDGE \
+ -DMAPI_ABI_HEADER=\"glapi_mapi_tmp.h\"
+
+AM_CFLAGS = $(VISIBILITY_CFLAGS)
+
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = glesv2.pc
+
+GLES_includedir = $(includedir)/GLES
+GLES_include_HEADERS = \
+ $(top_srcdir)/include/GLES/egl.h \
+ $(top_srcdir)/include/GLES/gl.h \
+ $(top_srcdir)/include/GLES/glext.h \
+ $(top_srcdir)/include/GLES/glplatform.h
+
+lib_LTLIBRARIES = libGLESv2.la
+
+libGLESv2_la_SOURCES = ../mapi/entry.c glapi_mapi_tmp.h
+libGLESv2_la_LIBADD = $(GLESv2_LIB_DEPS)
+libGLESv2_la_LDFLAGS = -version-number 2 -no-undefined
+
+include ../glapi/gen/glapi_gen.mk
+glapi_mapi_tmp.h: ../glapi/gen/gl_and_es_API.xml $(glapi_gen_mapi_deps)
+ $(call glapi_gen_mapi,$<,es2api)
+
+BUILT_SOURCES = glapi_mapi_tmp.h
+CLEANFILES = $(BUILT_SOURCES)
+
+# Provide compatibility with scripts for the old Mesa build system for
+# a while by putting a link to the driver into /lib of the build tree.
+all-local: libGLESv2.la
+ $(MKDIR_P) $(top_builddir)/$(LIB_DIR);
+ ln -f .libs/libGLESv2.so $(top_builddir)/$(LIB_DIR)/libGLESv2.so
+ ln -f .libs/libGLESv2.so.2 $(top_builddir)/$(LIB_DIR)/libGLESv2.so.2
+ ln -f .libs/libGLESv2.so.2.0.0 $(top_builddir)/$(LIB_DIR)/libGLESv2.so.2.0.0