summaryrefslogtreecommitdiffstats
path: root/src/mapi/es1api/Makefile.am
diff options
context:
space:
mode:
authorMatt Turner <[email protected]>2013-03-12 12:36:06 -0700
committerMatt Turner <[email protected]>2013-03-19 12:04:31 -0700
commit569bd281c1f5c3b64f4caab2c76611dfa2e6948c (patch)
tree42c1a9a8f33cf20d3f9f51852ef2307d63ad394c /src/mapi/es1api/Makefile.am
parent182895c4e691e9e783278f1448772e855ade7b33 (diff)
gles1: Add an ABI-check test
Checks that no functions are exported that are not part of the ABI. Note that currently we are exporting functions that are aliased to functions that are part of the ABI. They shouldn't be exported, but the XML descriptions don't adequately describe this case.
Diffstat (limited to 'src/mapi/es1api/Makefile.am')
-rw-r--r--src/mapi/es1api/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/mapi/es1api/Makefile.am b/src/mapi/es1api/Makefile.am
index c163a396c7f..bd3c60d7a7b 100644
--- a/src/mapi/es1api/Makefile.am
+++ b/src/mapi/es1api/Makefile.am
@@ -28,6 +28,8 @@ AM_CPPFLAGS = \
AM_CFLAGS = $(VISIBILITY_CFLAGS)
+TESTS = ABI-check
+
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = glesv1_cm.pc