summaryrefslogtreecommitdiffstats
path: root/src/mapi/es1api/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2014-03-13 05:44:33 +0000
committerEmil Velikov <[email protected]>2014-03-31 13:09:23 +0100
commitd187a150d45cbf5bd3476eab49be5057382c2c86 (patch)
tree21d55b22990122812b5875f31cc1d09966fedc39 /src/mapi/es1api/Makefile.am
parent902dc61f886c0d719ce25894bbc8032ede0f409b (diff)
automake: add -Wl,--no-undefined to all libraries
... apart from the dri drivers. With this final change we can build mesa without fear that the resulting libraries will have unresolved symbols. Signed-off-by: Emil Velikov <[email protected]> Reviewed-by: Matt Turner <[email protected]>
Diffstat (limited to 'src/mapi/es1api/Makefile.am')
-rw-r--r--src/mapi/es1api/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/mapi/es1api/Makefile.am b/src/mapi/es1api/Makefile.am
index b61f9cb1f66..b9581184a96 100644
--- a/src/mapi/es1api/Makefile.am
+++ b/src/mapi/es1api/Makefile.am
@@ -44,7 +44,10 @@ lib_LTLIBRARIES = libGLESv1_CM.la
libGLESv1_CM_la_SOURCES = ../entry.c glapi_mapi_tmp.h
libGLESv1_CM_la_LIBADD = $(GLESv1_CM_LIB_DEPS)
-libGLESv1_CM_la_LDFLAGS = -version-number 1:1 -no-undefined
+libGLESv1_CM_la_LDFLAGS = \
+ -no-undefined \
+ -version-number 1:1 \
+ -Wl,--no-undefined
if HAVE_SHARED_GLAPI
libGLESv1_CM_la_LIBADD += ../shared-glapi/libglapi.la