summaryrefslogtreecommitdiffstats
path: root/src/mapi/Makefile.am
diff options
context:
space:
mode:
authorMatt Turner <[email protected]>2014-12-17 18:50:25 -0800
committerMatt Turner <[email protected]>2015-01-23 14:28:44 -0800
commita37ae2ab922a0a7fceb9dba85dba11c26f4cf736 (patch)
treeb10e58df4b7f51a18ecd9c7f3d01f87f3edbb951 /src/mapi/Makefile.am
parent961def10745b52cb7430eaed8913a457a322556c (diff)
mapi: Build with subdir-objects.
Diffstat (limited to 'src/mapi/Makefile.am')
-rw-r--r--src/mapi/Makefile.am38
1 files changed, 27 insertions, 11 deletions
diff --git a/src/mapi/Makefile.am b/src/mapi/Makefile.am
index f6fc477a2b7..67946829198 100644
--- a/src/mapi/Makefile.am
+++ b/src/mapi/Makefile.am
@@ -19,11 +19,11 @@
# FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS
# IN THE SOFTWARE.
+AUTOMAKE_OPTIONS = subdir-objects
+
SUBDIRS =
TESTS =
-TOP = $(top_srcdir)
-
BUILT_SOURCES =
CLEANFILES = $(BUILT_SOURCES)
@@ -47,10 +47,20 @@ AM_CPPFLAGS = \
-I$(top_srcdir)/src/mapi \
-I$(top_builddir)/src/mapi
-GLAPI = $(top_srcdir)/src/mapi/glapi
include Makefile.sources
-include glapi/Makefile.sources
-include glapi/gen/glapi_gen.mk
+
+glapi_gen_mapi_deps := \
+ mapi_abi.py \
+ $(wildcard glapi/gen/*.xml) \
+ $(wildcard glapi/gen/*.py)
+
+# $(1): path to an XML file
+# $(2): name of the printer
+define glapi_gen_mapi
+@$(MKDIR_P) $(dir $@)
+$(AM_V_GEN)$(PYTHON2) $(PYTHON_FLAGS) $(srcdir)/mapi_abi.py \
+ --mode lib --printer $(2) $(1) > $@
+endef
if HAVE_SHARED_GLAPI
BUILT_SOURCES += shared-glapi/glapi_mapi_tmp.h
@@ -81,7 +91,7 @@ shared_glapi_test_LDADD = \
$(top_builddir)/src/gtest/libgtest.la
endif
-shared-glapi/glapi_mapi_tmp.h : $(GLAPI)/gen/gl_and_es_API.xml $(glapi_gen_mapi_deps)
+shared-glapi/glapi_mapi_tmp.h : glapi/gen/gl_and_es_API.xml $(glapi_gen_mapi_deps)
$(call glapi_gen_mapi,$<,shared-glapi)
if HAVE_OPENGL
@@ -89,16 +99,16 @@ noinst_LTLIBRARIES = glapi/libglapi.la
if HAVE_X86_ASM
if HAVE_X86_64_ASM
-GLAPI_ASM_SOURCES = $(X86_64_API)
+GLAPI_ASM_SOURCES = glapi/glapi_x86-64.S
else
-GLAPI_ASM_SOURCES = $(X86_API)
+GLAPI_ASM_SOURCES = glapi/glapi_x86.S
endif
endif
if HAVE_SPARC_ASM
-GLAPI_ASM_SOURCES = $(SPARC_API)
+GLAPI_ASM_SOURCES = glapi/glapi_sparc.S
endif
-glapi_libglapi_la_SOURCES = $(GLAPI_UTIL_SOURCES)
+glapi_libglapi_la_SOURCES = glapi/glapi_gentable.c
glapi_libglapi_la_CPPFLAGS = \
$(AM_CPPFLAGS) \
-I$(top_srcdir)/src/mapi/glapi \
@@ -113,7 +123,13 @@ else
glapi_libglapi_la_CPPFLAGS += \
-DMAPI_MODE_UTIL
glapi_libglapi_la_SOURCES += \
- $(GLAPI_SOURCES) \
+ glapi/glapi_dispatch.c \
+ glapi/glapi_entrypoint.c \
+ glapi/glapi_getproc.c \
+ glapi/glapi_nop.c \
+ glapi/glapi.c \
+ glapi/glapi.h \
+ glapi/glapi_priv.h \
$(GLAPI_ASM_SOURCES) \
$(MAPI_UTIL_FILES)